summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-27 17:03:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-27 17:03:42 +0000
commit99d79fbe0caa61d5c7febee9ec2ed9c0b1eea31a (patch)
tree8c5cde022d2ee58489cac9acdbce2a244dc26dc1 /dev-python/decorator
parentSet PYTHON_MODNAME. (diff)
downloadgentoo-2-99d79fbe0caa61d5c7febee9ec2ed9c0b1eea31a.tar.gz
gentoo-2-99d79fbe0caa61d5c7febee9ec2ed9c0b1eea31a.tar.bz2
gentoo-2-99d79fbe0caa61d5c7febee9ec2ed9c0b1eea31a.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/ChangeLog8
-rw-r--r--dev-python/decorator/decorator-3.2.0.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-python/decorator/ChangeLog b/dev-python/decorator/ChangeLog
index e183283a94e9..e0d2be4c8af9 100644
--- a/dev-python/decorator/ChangeLog
+++ b/dev-python/decorator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/decorator
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.14 2010/05/20 07:52:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.15 2010/05/27 17:03:42 arfrever Exp $
+
+*decorator-3.2.0 (27 May 2010)
+
+ 27 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +decorator-3.2.0.ebuild:
+ Version bump.
20 May 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
decorator-3.1.2.ebuild:
diff --git a/dev-python/decorator/decorator-3.2.0.ebuild b/dev-python/decorator/decorator-3.2.0.ebuild
new file mode 100644
index 000000000000..eb13a52ec395
--- /dev/null
+++ b/dev-python/decorator/decorator-3.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.2.0.ebuild,v 1.1 2010/05/27 17:03:42 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Simplifies the usage of decorators for the average programmer"
+HOMEPAGE="http://pypi.python.org/pypi/decorator"
+SRC_URI="http://pypi.python.org/packages/source/d/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DOCS="README.txt"
+PYTHON_MODNAME="decorator.py"
+
+src_test() {
+ testing() {
+ if [[ "${PYTHON_ABI}" == 3.* ]]; then
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" documentation3.py
+ else
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" documentation.py
+ fi
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc documentation.pdf documentation3.pdf || die "dodoc failed"
+ dohtml documentation.html documentation3.html || die "dohtml failed"
+ fi
+}