summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-12 09:13:31 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-12 09:13:31 +0000
commit54690a0f369f500f86502d444060702839951a3d (patch)
tree6f5541db58b6fc12a164b11e16005d981abc7929 /dev-python/django-compressor
parentMove pango dep to USE=X, Thanks Poly-C for reporting (diff)
downloadgentoo-2-54690a0f369f500f86502d444060702839951a3d.tar.gz
gentoo-2-54690a0f369f500f86502d444060702839951a3d.tar.bz2
gentoo-2-54690a0f369f500f86502d444060702839951a3d.zip
Verion Bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/django-compressor')
-rw-r--r--dev-python/django-compressor/ChangeLog8
-rw-r--r--dev-python/django-compressor/django-compressor-1.5.ebuild62
-rw-r--r--dev-python/django-compressor/metadata.xml2
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-python/django-compressor/ChangeLog b/dev-python/django-compressor/ChangeLog
index a7340770b07b..f87618dfe176 100644
--- a/dev-python/django-compressor/ChangeLog
+++ b/dev-python/django-compressor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-compressor
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-compressor/ChangeLog,v 1.12 2015/04/09 23:01:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-compressor/ChangeLog,v 1.13 2015/05/12 09:13:31 jlec Exp $
+
+*django-compressor-1.5 (12 May 2015)
+
+ 12 May 2015; Justin Lecher <jlec@gentoo.org> +django-compressor-1.5.ebuild,
+ metadata.xml:
+ Verion Bump
09 Apr 2015; Ian Delaney <idella4@gentoo.org> django-compressor-1.4.ebuild,
metadata.xml:
diff --git a/dev-python/django-compressor/django-compressor-1.5.ebuild b/dev-python/django-compressor/django-compressor-1.5.ebuild
new file mode 100644
index 000000000000..9bacb2c96be0
--- /dev/null
+++ b/dev-python/django-compressor/django-compressor-1.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-compressor/django-compressor-1.5.ebuild,v 1.1 2015/05/12 09:13:31 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+
+DESCRIPTION="Compresses linked and inline javascript or CSS into a single cached file"
+HOMEPAGE="https://github.com/django-compressor/django-compressor"
+SRC_URI="https://github.com/jezdez/django_compressor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/django-appconf-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/versiontools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-discover-runner[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/Coffin[${PYTHON_USEDEP}]
+ dev-python/jingo[${PYTHON_USEDEP}]
+ )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # https://github.com/django-compressor/django-compressor/issues/531 532
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ if python_is_python3; then
+ sed -e s':test_cachekey:_&:' -e s':test_css:_&:g' \
+ -i compressor/tests/test_base.py || die
+ fi
+ set -- django-admin.py test compressor --settings=compressor.test_settings
+ echo "$@"
+ "$@" || die "Tests failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-compressor/metadata.xml b/dev-python/django-compressor/metadata.xml
index 301d2207cc29..ee7e8b2450a8 100644
--- a/dev-python/django-compressor/metadata.xml
+++ b/dev-python/django-compressor/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
+ <herd>python</herd>
</pkgmetadata>