summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-10 08:58:24 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-10 08:58:24 +0000
commit4f912817feb14631a08f6fbd6fddc008b2dcde43 (patch)
tree19d3d80e95689e84639ec55ee38882dc6f0a2c56 /dev-python/django-recaptcha
parentTemporarily restrict the version of the slf4j-api dependency to <1.7.7; tempo... (diff)
downloadgentoo-2-4f912817feb14631a08f6fbd6fddc008b2dcde43.tar.gz
gentoo-2-4f912817feb14631a08f6fbd6fddc008b2dcde43.tar.bz2
gentoo-2-4f912817feb14631a08f6fbd6fddc008b2dcde43.zip
bump; drop py2.6 add pypy support, test dep & phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/django-recaptcha')
-rw-r--r--dev-python/django-recaptcha/ChangeLog7
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-1.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/django-recaptcha/ChangeLog b/dev-python/django-recaptcha/ChangeLog
index ac4d5ae62798..0988d7218948 100644
--- a/dev-python/django-recaptcha/ChangeLog
+++ b/dev-python/django-recaptcha/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django-recaptcha
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/ChangeLog,v 1.8 2014/04/26 11:01:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/ChangeLog,v 1.9 2014/05/10 08:58:24 idella4 Exp $
+
+*django-recaptcha-1.0 (10 May 2014)
+
+ 10 May 2014; Ian Delaney <idella4@gentoo.org> +django-recaptcha-1.0.ebuild:
+ bump; drop py2.6 add pypy support, test dep & phase
*django-recaptcha-0.0.9 (26 Apr 2014)
diff --git a/dev-python/django-recaptcha/django-recaptcha-1.0.ebuild b/dev-python/django-recaptcha/django-recaptcha-1.0.ebuild
new file mode 100644
index 000000000000..edb689c7a757
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-recaptcha/django-recaptcha-1.0.ebuild,v 1.1 2014/05/10 08:58:24 idella4 Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ >=dev-python/django-setuptest-0.0.6[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}