summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 17:25:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 17:25:42 +0000
commit0f04aa1101427faa9709abb484bd97ff791d709f (patch)
tree83a7f82584dd4c525df7006f799c561f70d79ad4 /dev-python/django
parentUse slot deps everywhere. (diff)
downloadgentoo-2-0f04aa1101427faa9709abb484bd97ff791d709f.tar.gz
gentoo-2-0f04aa1101427faa9709abb484bd97ff791d709f.tar.bz2
gentoo-2-0f04aa1101427faa9709abb484bd97ff791d709f.zip
Few small fixes to close #247204
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.0.2-r1.ebuild109
2 files changed, 115 insertions, 1 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index 7b5638d236eb..0c03dc04829a 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.29 2009/02/03 09:21:28 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.30 2009/02/15 17:25:42 patrick Exp $
+
+*django-1.0.2-r1 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +django-1.0.2-r1.ebuild:
+ Few small fixes to close #247204
*django-1.0.2 (03 Feb 2009)
diff --git a/dev-python/django/django-1.0.2-r1.ebuild b/dev-python/django/django-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..50da96eb1e96
--- /dev/null
+++ b/dev-python/django/django-1.0.2-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.2-r1.ebuild,v 1.1 2009/02/15 17:25:42 patrick Exp $
+EAPI=2
+
+inherit bash-completion subversion distutils multilib versionator webapp
+
+MY_P="${P/#d/D}-final"
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="High-level python web framework"
+HOMEPAGE="http://www.djangoproject.com/"
+SRC_URI="http://media.djangoproject.com/releases/${PV}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples mysql postgres sqlite3 test"
+
+RDEPEND="dev-python/imaging
+ sqlite3? ( || (
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
+ >=dev-lang/python-2.5[sqlite] ) )
+ test? ( || (
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
+ >=dev-lang/python-2.5[sqlite] ) )
+ postgres? ( dev-python/psycopg )
+ mysql? ( >=dev-python/mysql-python-1.2.1_p2 )
+ doc? ( >=dev-python/sphinx-0.3 )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/* AUTHORS"
+
+src_unpack() {
+ distutils_src_unpack
+ if use test; then
+ local repo_uri
+ repo_uri="http://code.djangoproject.com/svn/${PN}/tags/releases/${PV}/tests/"
+ subversion_fetch ${repo_uri} tests
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ pushd docs
+ emake html || die "docs failed"
+ popd
+ fi
+}
+
+src_test() {
+ einfo "Running tests."
+ cat >> tests/settings.py << __EOF__
+DATABASE_ENGINE='sqlite3'
+ROOT_URLCONF='tests/urls.py'
+SITE_ID=1
+__EOF__
+ PYTHONPATH="." ${python} tests/runtests.py --settings=settings -v1 \
+ || die "tests failed"
+}
+
+src_install() {
+ distutils_python_version
+ site_pkgs="$(python_get_sitedir)"
+ export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
+ dodir ${site_pkgs}
+
+ distutils_src_install
+
+ dobashcompletion extras/django_bash_completion
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ if use doc ; then
+ mv docs/_build/html/{_,.}sources
+ dohtml txt -r docs/_build/html/*
+ fi
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r "${D}/${site_pkgs}"/django/contrib/admin/media/*
+
+ #webapp_postinst_txt en "${WORKDIR}"/postinstall-en.txt
+ webapp_src_install
+}
+
+pkg_preinst() {
+ :
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ distutils_pkg_postinst
+ einfo "Now, Django has the best of both worlds with Gentoo,"
+ einfo "ease of deployment for production and development."
+ echo
+ elog "A copy of the admin media is available to"
+ elog "webapp-config for installation in a webroot,"
+ elog "as well as the traditional location in python's"
+ elog "site-packages dir for easy development"
+ echo
+ echo
+ ewarn "If you build Django-1.0.2 without USE=\"vhosts\""
+ ewarn "webapp-config will automatically install the"
+ ewarn "admin media into the localhost webroot."
+}