summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-10-06 18:42:46 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-10-06 18:42:46 +0000
commitcc54da9bfd71e95994c9d4e64477b2301f1ae1ee (patch)
tree424ef37ff7d60a49e8c16040ff58738217a56a28 /dev-python/django
parentFix potential DoS issue. fdo bug #17803. Gentoo bug #240308 (diff)
downloadgentoo-2-cc54da9bfd71e95994c9d4e64477b2301f1ae1ee.tar.gz
gentoo-2-cc54da9bfd71e95994c9d4e64477b2301f1ae1ee.tar.bz2
gentoo-2-cc54da9bfd71e95994c9d4e64477b2301f1ae1ee.zip
Fixed tests, added sphinx doc generation, dropped ppc64 until sphinx is keyworded, use EAPI1 for slots
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.0.ebuild43
-rw-r--r--dev-python/django/django-9999.ebuild4
3 files changed, 39 insertions, 15 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index ec2c206fe187..67a492568f3c 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.25 2008/09/04 06:21:44 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.26 2008/10/06 18:42:46 pythonhead Exp $
+
+ 06 Oct 2008; Rob Cakebread <pythonhead@gentoo.org> django-1.0.ebuild,
+ django-9999.ebuild:
+ Fixed tests, added sphinx doc generation, dropped ppc64 until sphinx is
+ keyworded, use EAPI1 for slots
*django-1.0 (04 Sep 2008)
diff --git a/dev-python/django/django-1.0.ebuild b/dev-python/django/django-1.0.ebuild
index e2314eb5628c..c9bc5481082f 100644
--- a/dev-python/django/django-1.0.ebuild
+++ b/dev-python/django/django-1.0.ebuild
@@ -1,35 +1,52 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.ebuild,v 1.2 2008/09/04 14:52:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.0.ebuild,v 1.3 2008/10/06 18:42:46 pythonhead Exp $
-inherit bash-completion distutils eutils versionator
+EAPI="1"
+inherit bash-completion distutils versionator
DESCRIPTION="high-level python web framework"
HOMEPAGE="http://www.djangoproject.com/"
SRC_URI="http://media.djangoproject.com/releases/${PV}/Django-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="examples mysql postgres sqlite3 test"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc examples mysql postgres sqlite3 test"
RDEPEND="dev-python/imaging
sqlite3? ( || (
- ( >=dev-python/pysqlite-2.0.3 <dev-lang/python-2.5 )
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
>=dev-lang/python-2.5 ) )
test? ( || (
- ( >=dev-python/pysqlite-2.0.3 <dev-lang/python-2.5 )
+ ( dev-python/pysqlite:2 <dev-lang/python-2.5 )
>=dev-lang/python-2.5 ) )
postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
+ mysql? ( >=dev-python/mysql-python-1.2.1_p2 )
+ doc? ( >=dev-python/sphinx-0.3 )"
DEPEND="${RDEPEND}"
S="${WORKDIR}/${P/#d/D}"
DOCS="docs/* AUTHORS"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #Submitted upstream http://code.djangoproject.com/ticket/8865
+ #by pythonhead, accepted in trunk
+ epatch "${FILESDIR}/${P}"-fields.py.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc ; then
+ cd docs
+ emake html || die "docs failed"
+ fi
+}
+
src_test() {
- #Test fails, reported upstream http://code.djangoproject.com/ticket/8865
- echo "tests='''pass'''" > tests/regressiontests/forms/fields.py
cat >> tests/settings.py << __EOF__
DATABASE_ENGINE='sqlite3'
ROOT_URLCONF='tests/urls.py'
@@ -39,11 +56,9 @@ __EOF__
}
src_install() {
- #TODO: Use sphinx to generate docs when sphinx is keyworded for
- #all arches django is
distutils_python_version
- site_pkgs="/usr/$(get_libdir)/python${PYVER}/site-packages/"
+ site_pkgs="$(python_get_sitedir)"
export PYTHONPATH="${PYTHONPATH}:${D}/${site_pkgs}"
dodir ${site_pkgs}
@@ -55,4 +70,8 @@ src_install() {
insinto /usr/share/doc/${PF}
doins -r examples
fi
+ if use doc ; then
+ rm -Rf docs/_build/html/_sources
+ dohtml txt -r docs/_build/html/*
+ fi
}
diff --git a/dev-python/django/django-9999.ebuild b/dev-python/django/django-9999.ebuild
index 0c8c92edac7b..77d34c40c061 100644
--- a/dev-python/django/django-9999.ebuild
+++ b/dev-python/django/django-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.1 2008/06/07 12:51:16 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-9999.ebuild,v 1.2 2008/10/06 18:42:46 pythonhead Exp $
ESVN_REPO_URI="http://code.djangoproject.com/svn/django/trunk/"
@@ -10,7 +10,7 @@ DESCRIPTION="high-level python web framework"
HOMEPAGE="http://www.djangoproject.com/"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE="doc examples mysql postgres sqlite test"
RDEPEND="dev-python/imaging