summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-08 23:43:42 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-08 23:43:42 +0000
commit0e82fc630d9a3cc3d2aadd715ab81fecad0ea6ea (patch)
tree062edea072387f5ee8ce510e4da79b4eb1b696ec /dev-python/dulwich
parentRestore stable ebuild. (diff)
downloadgentoo-2-0e82fc630d9a3cc3d2aadd715ab81fecad0ea6ea.tar.gz
gentoo-2-0e82fc630d9a3cc3d2aadd715ab81fecad0ea6ea.tar.bz2
gentoo-2-0e82fc630d9a3cc3d2aadd715ab81fecad0ea6ea.zip
General cleanup; remove pointless sed.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog5
-rw-r--r--dev-python/dulwich/dulwich-0.9.0-r1.ebuild23
2 files changed, 12 insertions, 16 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index c858ea16b1ca..e5c13578806b 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.65 2013/06/08 23:38:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.66 2013/06/08 23:43:42 floppym Exp $
+
+ 08 Jun 2013; Mike Gilbert <floppym@gentoo.org> dulwich-0.9.0-r1.ebuild:
+ General cleanup; remove pointless sed.
*dulwich-0.8.7 (08 Jun 2013)
diff --git a/dev-python/dulwich/dulwich-0.9.0-r1.ebuild b/dev-python/dulwich/dulwich-0.9.0-r1.ebuild
index 3c2c82ce0688..a3ce8d51ebfc 100644
--- a/dev-python/dulwich/dulwich-0.9.0-r1.ebuild
+++ b/dev-python/dulwich/dulwich-0.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.9.0-r1.ebuild,v 1.1 2013/06/08 13:20:59 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.9.0-r1.ebuild,v 1.2 2013/06/08 23:43:42 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
@@ -17,28 +17,21 @@ KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-ma
IUSE="doc test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ )"
RDEPEND=""
-python_prepare_all() {
- sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
- use test && DISTUTILS_IN_SOURCE_BUILD=1
- distutils-r1_python_prepare_all
-}
+DISTUTILS_IN_SOURCE_BUILD=1
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- pushd "${BUILD_DIR}"/../ &> /dev/null
- local module
- for module in _diff_tree _objects _pack; do
- ln -fs "${BUILD_DIR}/lib/${PN}/${module}.so" "dulwich/${module}.so" \
- || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation_and_version)"
- done
- nosetests || die || "Tests failed under ${EPYTHON}"
+ ln -s "${BUILD_DIR}"/lib/dulwich/*.so dulwich/ || die
+ nosetests || die "Tests failed under ${EPYTHON}"
}
python_install_all() {