summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2014-03-30 20:39:18 +0000
committerDirkjan Ochtman <djc@gentoo.org>2014-03-30 20:39:18 +0000
commitc38d50427fcf8d7633f1a350ece0c1b47e328195 (patch)
tree975a45de422c4e61a8d57e758710d9f5df706eac /dev-python/dulwich
parentRemove old versions. (diff)
downloadgentoo-2-c38d50427fcf8d7633f1a350ece0c1b47e328195.tar.gz
gentoo-2-c38d50427fcf8d7633f1a350ece0c1b47e328195.tar.bz2
gentoo-2-c38d50427fcf8d7633f1a350ece0c1b47e328195.zip
Remove unused patch.
(Portage version: 2.2.9-r1/cvs/Linux x86_64, signed Manifest commit with key 30380381)
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/ChangeLog6
-rw-r--r--dev-python/dulwich/files/dulwich-0.8.0-darwin.patch36
2 files changed, 5 insertions, 37 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 8271f1be4e35..ad4185ce5daa 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.76 2014/03/30 20:38:17 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.77 2014/03/30 20:39:18 djc Exp $
+
+ 30 Mar 2014; Dirkjan Ochtman <djc@gentoo.org>
+ -files/dulwich-0.8.0-darwin.patch:
+ Remove unused patch.
30 Mar 2014; Dirkjan Ochtman <djc@gentoo.org> -dulwich-0.8.7-r1.ebuild,
-dulwich-0.8.7.ebuild, -dulwich-0.9.0-r1.ebuild, -dulwich-0.9.1.ebuild,
diff --git a/dev-python/dulwich/files/dulwich-0.8.0-darwin.patch b/dev-python/dulwich/files/dulwich-0.8.0-darwin.patch
deleted file mode 100644
index b0d888bccc4c..000000000000
--- a/dev-python/dulwich/files/dulwich-0.8.0-darwin.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-https://bugs.launchpad.net/dulwich/+bug/822427
-
---- dulwich/_objects.c
-+++ dulwich/_objects.c
-@@ -21,21 +21,15 @@
- #include <stdlib.h>
- #include <sys/stat.h>
-
--#if defined(__APPLE__)
--#include <Availability.h>
--#endif
--
- #if (PY_VERSION_HEX < 0x02050000)
- typedef int Py_ssize_t;
- #endif
-
--#if defined(__MINGW32_VERSION) || (defined(__APPLE__) && __MAC_OS_X_VERSION_MIN_REQUIRED < 1070)
--size_t strnlen(char *text, size_t maxlen)
-+static size_t dwstrnlen(char *text, size_t maxlen)
- {
- const char *last = memchr(text, '\0', maxlen);
- return last ? (size_t) (last - text) : maxlen;
- }
--#endif
-
- #define bytehex(x) (((x)<0xa)?('0'+(x)):('a'-0xa+(x)))
-
-@@ -98,7 +92,7 @@
-
- text++;
-
-- namelen = strnlen(text, len - (text - start));
-+ namelen = dwstrnlen(text, len - (text - start));
-
- name = PyString_FromStringAndSize(text, namelen);
- if (name == NULL) {