summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-15 19:12:13 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-15 19:12:13 +0000
commit2727461d502679f3c1ac811f2a91afe29ba7ef00 (patch)
tree6d651fe0cd2ca6400596700a7dc5824140517c93 /dev-python/enable
parentStable for x86, wrt bug #465910 (diff)
downloadgentoo-2-2727461d502679f3c1ac811f2a91afe29ba7ef00.tar.gz
gentoo-2-2727461d502679f3c1ac811f2a91afe29ba7ef00.tar.bz2
gentoo-2-2727461d502679f3c1ac811f2a91afe29ba7ef00.zip
migration -> distutils-r1
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/ChangeLog7
-rw-r--r--dev-python/enable/enable-4.2.0-r1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index 8ca83e224551..75c843ae53f9 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/enable
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.21 2013/04/03 08:59:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.22 2013/04/15 19:12:13 idella4 Exp $
+
+*enable-4.2.0-r1 (15 Apr 2013)
+
+ 15 Apr 2013; Ian Delaney <idella4@gentoo.org> +enable-4.2.0-r1.ebuild:
+ migration -> distutils-r1
03 Apr 2013; Patrick Lauer <patrick@gentoo.org> enable-4.2.0.ebuild:
Fix dependencies
diff --git a/dev-python/enable/enable-4.2.0-r1.ebuild b/dev-python/enable/enable-4.2.0-r1.ebuild
new file mode 100644
index 000000000000..2ed599cc8106
--- /dev/null
+++ b/dev-python/enable/enable-4.2.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-4.2.0-r1.ebuild,v 1.1 2013/04/15 19:12:13 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
+HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/enable"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz
+ http://dev.gentoo.org/~idella4/${PN}-4-TestsPaths.patch"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]
+ >=media-libs/freetype-2
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-lang/swig
+ dev-python/cython
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+# Remove check for Darwin systems, set py.test style xfails,
+# Re-set import paths in tests, 'enabling' enable to find its own in source modules!!?!
+# https://github.com/enthought/enable/issues/99
+PATCHES=( "${FILESDIR}"/${PN}-4-rogue-tests.patch \
+ "${DISTDIR}"/${PN}-4-TestsPaths.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Hardcoding build-2.7, 2.7 being the only fully capable candidate
+
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ find -name "*LICENSE*.txt" -delete
+ distutils-r1_python_install_all
+
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}