summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-27 22:30:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-27 22:30:16 +0000
commit49a04c78e3a3d844d9dd52d8de1f36191f485277 (patch)
tree330b78e0cf8e00801ed4156096af7d1682b4b406 /dev-python/enable
parentDrop the recently added stable ppc keyword cause of QA issues, bug #326217 (diff)
downloadgentoo-2-49a04c78e3a3d844d9dd52d8de1f36191f485277.tar.gz
gentoo-2-49a04c78e3a3d844d9dd52d8de1f36191f485277.tar.bz2
gentoo-2-49a04c78e3a3d844d9dd52d8de1f36191f485277.zip
Version bump.
(Portage version: 2.2.0_alpha28_p40/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/ChangeLog8
-rw-r--r--dev-python/enable/enable-3.4.1.ebuild88
2 files changed, 95 insertions, 1 deletions
diff --git a/dev-python/enable/ChangeLog b/dev-python/enable/ChangeLog
index bd08f1d209f5..bced5e53159f 100644
--- a/dev-python/enable/ChangeLog
+++ b/dev-python/enable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/enable
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.10 2011/01/30 17:02:25 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/ChangeLog,v 1.11 2011/03/27 22:30:16 arfrever Exp $
+
+*enable-3.4.1 (27 Mar 2011)
+
+ 27 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +enable-3.4.1.ebuild:
+ Version bump.
*enable-3.4.0 (30 Jan 2011)
diff --git a/dev-python/enable/enable-3.4.1.ebuild b/dev-python/enable/enable-3.4.1.ebuild
new file mode 100644
index 000000000000..277e4668dedb
--- /dev/null
+++ b/dev-python/enable/enable-3.4.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/enable/enable-3.4.1.ebuild,v 1.1 2011/03/27 22:30:16 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils virtualx
+
+MY_PN="Enable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enthought Tool Suite: Drawing and interaction packages"
+HOMEPAGE="http://code.enthought.com/projects/enable/ http://pypi.python.org/pypi/Enable"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/enthoughtbase-3.1.0
+ dev-python/numpy
+ dev-python/reportlab
+ dev-python/setuptools
+ >=dev-python/traitsgui-3.6.0[wxwidgets]
+ >=media-libs/freetype-2
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-python/cython
+ doc? ( dev-python/sphinx )
+ test? (
+ dev-python/coverage
+ dev-python/nose
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ x11-apps/xhost
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="docs/*.txt"
+PYTHON_MODNAME="enthought"
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-3.3.0-nofreetype.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ VIRTUALX_COMMAND="distutils_src_test" virtualmake
+}
+
+src_install() {
+ find -name "*LICENSE.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}