summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 17:45:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-12 17:45:26 +0000
commite8b0f8c79aa6b2233062f02a6ceb4006888b70e4 (patch)
tree5db06dd85d9bcb75711b95c8037d709177005e49 /dev-python/flask
parentalpha/ia64/s390/sh/sparc stable wrt #344827 (diff)
downloadgentoo-2-e8b0f8c79aa6b2233062f02a6ceb4006888b70e4.tar.gz
gentoo-2-e8b0f8c79aa6b2233062f02a6ceb4006888b70e4.tar.bz2
gentoo-2-e8b0f8c79aa6b2233062f02a6ceb4006888b70e4.zip
Fix dependencies.
(Portage version: 2.2.0_alpha23_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog8
-rw-r--r--dev-python/flask/flask-0.6.1.ebuild17
2 files changed, 17 insertions, 8 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 8247502e33bd..9ece23873f21 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/flask
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.6 2010/12/31 22:31:02 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.7 2011/02/12 17:45:26 arfrever Exp $
+
+ 12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ flask-0.6.1.ebuild:
+ Fix dependencies.
*flask-0.6.1 (31 Dec 2010)
diff --git a/dev-python/flask/flask-0.6.1.ebuild b/dev-python/flask/flask-0.6.1.ebuild
index 38f86c02013b..e9d00fe10756 100644
--- a/dev-python/flask/flask-0.6.1.ebuild
+++ b/dev-python/flask/flask-0.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.6.1.ebuild,v 1.1 2010/12/31 22:31:02 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.6.1.ebuild,v 1.2 2011/02/12 17:45:26 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -21,7 +21,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples test"
-RDEPEND=">=dev-python/jinja-2.4
+RDEPEND="dev-python/blinker
+ >=dev-python/jinja-2.4
dev-python/setuptools
>=dev-python/werkzeug-0.6.1"
DEPEND="${RDEPEND}
@@ -34,8 +35,9 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
- cd docs
+ pushd docs > /dev/null
PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ popd > /dev/null
fi
}
@@ -50,11 +52,14 @@ src_install() {
distutils_src_install
if use doc; then
- dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ pushd docs/_build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
fi
if use examples; then
- insinto "/usr/share/doc/${PF}"
+ insinto /usr/share/doc/${PF}
doins -r examples || die "Installation of examples failed"
fi
}