summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-12 12:59:51 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-12 12:59:51 +0000
commita278cdcd4d7badd407dc2a572dfce9b1d83e35b1 (patch)
treeab10f72b324e0d6bf401597a5b27de42167c2643 /dev-python/flup
parentFix typo: extra apostrophe being shell syntax error. (diff)
downloadgentoo-2-a278cdcd4d7badd407dc2a572dfce9b1d83e35b1.tar.gz
gentoo-2-a278cdcd4d7badd407dc2a572dfce9b1d83e35b1.tar.bz2
gentoo-2-a278cdcd4d7badd407dc2a572dfce9b1d83e35b1.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha162/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/flup')
-rw-r--r--dev-python/flup/ChangeLog10
-rw-r--r--dev-python/flup/flup-1.0.2-r1.ebuild21
2 files changed, 28 insertions, 3 deletions
diff --git a/dev-python/flup/ChangeLog b/dev-python/flup/ChangeLog
index ebc1de6b806d..ef06df9539aa 100644
--- a/dev-python/flup/ChangeLog
+++ b/dev-python/flup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flup
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flup/ChangeLog,v 1.16 2012/09/22 02:08:12 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flup/ChangeLog,v 1.17 2013/02/12 12:59:51 mgorny Exp $
+
+*flup-1.0.2-r1 (12 Feb 2013)
+
+ 12 Feb 2013; Michał Górny <mgorny@gentoo.org> +flup-1.0.2-r1.ebuild:
+ Migrate to distutils-r1.
22 Sep 2012; Anthony G. Basile <blueness@gentoo.org> flup-1.0.2.ebuild:
keyword ~arm, bug #433978
@@ -56,4 +61,3 @@
13 Jan 2007; Tiziano Müller <dev-zero@gentoo.org> +metadata.xml,
+flup-0.5_p2307.ebuild:
New ebuild for bug #100784.
-
diff --git a/dev-python/flup/flup-1.0.2-r1.ebuild b/dev-python/flup/flup-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..2e893b730c90
--- /dev/null
+++ b/dev-python/flup/flup-1.0.2-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flup/flup-1.0.2-r1.ebuild,v 1.1 2013/02/12 12:59:51 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Random assortment of WSGI servers"
+HOMEPAGE="http://trac.saddi.com/flup http://pypi.python.org/pypi/flup"
+SRC_URI="http://www.saddi.com/software/${PN}/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"