summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-02-15 21:27:49 +0000
committerMichał Górny <mgorny@gentoo.org>2013-02-15 21:27:49 +0000
commit5f34a3c33c6bc5eb6b811cac80f8d8eafdd18fbb (patch)
tree02197af8988f32ccce821b34da3ac36b46789da2 /dev-python/fpconst
parentVersion bump, rewriten in texlua dropping the ruby dep. (diff)
downloadgentoo-2-5f34a3c33c6bc5eb6b811cac80f8d8eafdd18fbb.tar.gz
gentoo-2-5f34a3c33c6bc5eb6b811cac80f8d8eafdd18fbb.tar.bz2
gentoo-2-5f34a3c33c6bc5eb6b811cac80f8d8eafdd18fbb.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/fpconst')
-rw-r--r--dev-python/fpconst/ChangeLog10
-rw-r--r--dev-python/fpconst/fpconst-0.7.3-r1.ebuild27
2 files changed, 34 insertions, 3 deletions
diff --git a/dev-python/fpconst/ChangeLog b/dev-python/fpconst/ChangeLog
index 6ac65b68b4f2..bfe103fc0f1a 100644
--- a/dev-python/fpconst/ChangeLog
+++ b/dev-python/fpconst/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/fpconst
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fpconst/ChangeLog,v 1.35 2012/05/13 20:17:37 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fpconst/ChangeLog,v 1.36 2013/02/15 21:27:49 mgorny Exp $
+
+*fpconst-0.7.3-r1 (15 Feb 2013)
+
+ 15 Feb 2013; Michał Górny <mgorny@gentoo.org> +fpconst-0.7.3-r1.ebuild:
+ Migrate to distutils-r1.
13 May 2012; Alexis Ballier <aballier@gentoo.org> fpconst-0.7.3.ebuild:
keyword ~amd64-fbsd
@@ -116,4 +121,3 @@
03 Jan 2004; Bryan Østergaard,,, <kloeri@gentoo.org> fpconst-0.6.0.ebuild,
metadata.xml:
Initial import
-
diff --git a/dev-python/fpconst/fpconst-0.7.3-r1.ebuild b/dev-python/fpconst/fpconst-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..83237551aece
--- /dev/null
+++ b/dev-python/fpconst/fpconst-0.7.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fpconst/fpconst-0.7.3-r1.ebuild,v 1.1 2013/02/15 21:27:49 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Module for handling IEEE 754 floating point special values"
+HOMEPAGE="http://chaco.bst.rochester.edu:8080/statcomp/projects/RStatServer/fpconst/ http://pypi.python.org/pypi/fpconst http://sourceforge.net/projects/rsoap/files/"
+SRC_URI="mirror://sourceforge/rsoap/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS=( CHANGELOG README pep-0754.txt )
+
+python_test() {
+ "${PYTHON}" -m fpconst || die "Self-tests fail with ${EPYTHON}"
+}