summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-04-14 00:24:55 +0000
committerSebastian Pipping <sping@gentoo.org>2010-04-14 00:24:55 +0000
commitc7b98d75e642f1ab5d51c8b03135dd59a7c2860c (patch)
tree89fd2fc6732e81ce98cc6f2416fcd432e52dcac4 /dev-python/fuse-python
parentVersion bump (diff)
downloadgentoo-2-c7b98d75e642f1ab5d51c8b03135dd59a7c2860c.tar.gz
gentoo-2-c7b98d75e642f1ab5d51c8b03135dd59a7c2860c.tar.bz2
gentoo-2-c7b98d75e642f1ab5d51c8b03135dd59a7c2860c.zip
dev-python/fuse-python: Integrate patch to fix ctors
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'dev-python/fuse-python')
-rw-r--r--dev-python/fuse-python/ChangeLog12
-rw-r--r--dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch32
-rw-r--r--dev-python/fuse-python/fuse-python-0.2-r1.ebuild29
-rw-r--r--dev-python/fuse-python/metadata.xml4
4 files changed, 75 insertions, 2 deletions
diff --git a/dev-python/fuse-python/ChangeLog b/dev-python/fuse-python/ChangeLog
index bdb222658e81..b5a719237bbe 100644
--- a/dev-python/fuse-python/ChangeLog
+++ b/dev-python/fuse-python/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/fuse-python
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fuse-python/ChangeLog,v 1.10 2009/12/20 22:26:36 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fuse-python/ChangeLog,v 1.11 2010/04/14 00:24:55 sping Exp $
+
+*fuse-python-0.2-r1 (14 Apr 2010)
+
+ 14 Apr 2010; Sebastian Pipping <sping@gentoo.org>
+ +fuse-python-0.2-r1.ebuild, +files/fuse-python-0.2-fix-ctors.patch,
+ metadata.xml:
+ Integrate patch to fix ctors (will be in 0.2.1)
+ Add me as maintainer
20 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
fuse-python-0.2.ebuild:
diff --git a/dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch b/dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch
new file mode 100644
index 000000000000..4ec50f2f3508
--- /dev/null
+++ b/dev-python/fuse-python/files/fuse-python-0.2-fix-ctors.patch
@@ -0,0 +1,32 @@
+--- fuse.py
++++ fuse.py
+@@ -461,13 +462,14 @@
+ FUSE, see ``fuse.h``).
+ """
+
+- def __init__(self, name, **kw):
++ def __init__(self, name=None, **kw):
+
+ self.l_type = None
+ self.l_start = None
+ self.l_len = None
+ self.l_pid = None
+
++ kw['name'] = name
+ FuseStruct.__init__(self, **kw)
+
+
+@@ -477,11 +479,12 @@
+ http://www.opengroup.org/onlinepubs/009695399/basedefs/time.h.html
+ """
+
+- def __init__(self, name, **kw):
++ def __init__(self, name=None, **kw):
+
+ self.tv_sec = None
+ self.tv_nsec = None
+
++ kw['name'] = name
+ FuseStruct.__init__(self, **kw)
+
+
diff --git a/dev-python/fuse-python/fuse-python-0.2-r1.ebuild b/dev-python/fuse-python/fuse-python-0.2-r1.ebuild
new file mode 100644
index 000000000000..2e1766d82f4f
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-0.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fuse-python/fuse-python-0.2-r1.ebuild,v 1.1 2010/04/14 00:24:55 sping Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils
+
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="http://fuse.sourceforge.net/wiki/index.php/FusePython"
+
+SRC_URI="mirror://sourceforge/fuse/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=sys-fs/fuse-2.0"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="fuse.py fuseparts"
+
+src_prepare () {
+ distutils_src_prepare
+ epatch "${FILESDIR}/fuse_python_accept_none.patch" \
+ "${FILESDIR}"/${P}-fix-ctors.patch
+}
diff --git a/dev-python/fuse-python/metadata.xml b/dev-python/fuse-python/metadata.xml
index bb3ae92ab785..3a6565d0e974 100644
--- a/dev-python/fuse-python/metadata.xml
+++ b/dev-python/fuse-python/metadata.xml
@@ -3,6 +3,10 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+</maintainer>
+<maintainer>
<email>jokey@gentoo.org</email>
<name>Markus Ullmann</name>
</maintainer>