summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-10-02 13:43:50 +0000
committerIan Delaney <idella4@gentoo.org>2014-10-02 13:43:50 +0000
commit4b3ece4ecbbb3bbd207c78500a7db7022614167b (patch)
tree066b772bf445ed0d4988245ea92f89fb36198740 /dev-python/futures/futures-2.2.0.ebuild
parentWhitespace. (diff)
downloadgentoo-2-4b3ece4ecbbb3bbd207c78500a7db7022614167b.tar.gz
gentoo-2-4b3ece4ecbbb3bbd207c78500a7db7022614167b.tar.bz2
gentoo-2-4b3ece4ecbbb3bbd207c78500a7db7022614167b.zip
tidy
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/futures/futures-2.2.0.ebuild')
-rw-r--r--dev-python/futures/futures-2.2.0.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/futures/futures-2.2.0.ebuild b/dev-python/futures/futures-2.2.0.ebuild
index afffc5037964..8d98e3478f50 100644
--- a/dev-python/futures/futures-2.2.0.ebuild
+++ b/dev-python/futures/futures-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/futures/futures-2.2.0.ebuild,v 1.1 2014/10/01 02:53:59 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/futures/futures-2.2.0.ebuild,v 1.2 2014/10/02 13:43:50 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
@@ -17,8 +17,6 @@ IUSE="doc"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-# Requ'd for failing tests under pypy
-DISTUTILS_IN_SOURCE_BUILD=1
python_compile_all() {
use doc && emake -C docs html
@@ -28,7 +26,8 @@ python_test() {
# tests that fail under pypy
# http://code.google.com/p/pythonfutures/issues/detail?id=27
if [[ "${EPYTHON}" == pypy ]]; then
- sed -e 's:test_del_shutdown:_&:g' -e 's:test_repr:_&:' -i test_futures.py || die
+ sed -e 's:test_del_shutdown:_&:g' \
+ -e 's:test_repr:_&:' -i test_futures.py || die
fi
"${PYTHON}" test_futures.py || die "Tests fail with ${EPYTHON}"
}