summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-10 16:23:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-10 16:23:39 +0000
commitc43cf349569d728b99ea0ef3ba06d4d316dcf5bb (patch)
tree1e46cfc6c9a64180e1be9a02762cede09410ac1b /dev-python/gdata
parentCleaning out old, keeping latest ~ppc (diff)
downloadgentoo-2-c43cf349569d728b99ea0ef3ba06d4d316dcf5bb.tar.gz
gentoo-2-c43cf349569d728b99ea0ef3ba06d4d316dcf5bb.tar.bz2
gentoo-2-c43cf349569d728b99ea0ef3ba06d4d316dcf5bb.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 13976-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/ChangeLog8
-rw-r--r--dev-python/gdata/gdata-2.0.1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/gdata/ChangeLog b/dev-python/gdata/ChangeLog
index 07f4cbb15531..0742c07e2d0e 100644
--- a/dev-python/gdata/ChangeLog
+++ b/dev-python/gdata/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gdata
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.27 2009/08/02 14:26:44 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/ChangeLog,v 1.28 2009/08/10 16:23:39 arfrever Exp $
+
+*gdata-2.0.1 (10 Aug 2009)
+
+ 10 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +gdata-2.0.1.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
02 Aug 2009; nixnut <nixnut@gentoo.org> gdata-2.0.0.ebuild:
ppc stable #277347
diff --git a/dev-python/gdata/gdata-2.0.1.ebuild b/dev-python/gdata/gdata-2.0.1.ebuild
new file mode 100644
index 000000000000..744e6501a206
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdata/gdata-2.0.1.ebuild,v 1.1 2009/08/10 16:23:39 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="gdata-${PV}"
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="http://code.google.com/p/gdata-python-client/"
+SRC_URI="http://gdata-python-client.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( >=dev-lang/python-2.5 dev-python/elementtree )"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+PYTHON_MODNAME="atom gdata"
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_data_tests.py -v || die "Data tests failed with Python ${PYTHON_ABI}"
+
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ # PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" tests/run_service_tests.py -v || die "Service tests failed with Python ${PYTHON_ABI}"
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}