summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-09-22 08:04:36 +0000
committerMart Raudsepp <leio@gentoo.org>2008-09-22 08:04:36 +0000
commitf2568d5ccbf5e94d05d539eddf49ddb26699157b (patch)
tree923de3ba41c340151642fea35d67a5402665720e /dev-python/gnome-python-base
parentRemove old. (diff)
downloadgentoo-2-f2568d5ccbf5e94d05d539eddf49ddb26699157b.tar.gz
gentoo-2-f2568d5ccbf5e94d05d539eddf49ddb26699157b.tar.bz2
gentoo-2-f2568d5ccbf5e94d05d539eddf49ddb26699157b.zip
Version bump for forwards compatibility with upcoming major pygobject/pygtk versions (pygtk-codegen-2.0 move to pygobject-codegen-2.0)
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/ChangeLog9
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.22.2.ebuild34
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-python/gnome-python-base/ChangeLog b/dev-python/gnome-python-base/ChangeLog
index 330a13d981b2..1d788eca8511 100644
--- a/dev-python/gnome-python-base/ChangeLog
+++ b/dev-python/gnome-python-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/gnome-python-base
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.2 2008/08/24 07:22:45 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.3 2008/09/22 08:04:36 leio Exp $
+
+*gnome-python-base-2.22.2 (22 Sep 2008)
+
+ 22 Sep 2008; Mart Raudsepp <leio@gentoo.org>
+ +gnome-python-base-2.22.2.ebuild:
+ Version bump for forwards compatibility with upcoming major
+ pygobject/pygtk versions (pygtk-codegen-2.0 move to pygobject-codegen-2.0)
*gnome-python-base-2.22.1 (24 Aug 2008)
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.22.2.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.22.2.ebuild
new file mode 100644
index 000000000000..b16ff73f0069
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.22.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.22.2.ebuild,v 1.1 2008/09/22 08:04:36 leio Exp $
+
+inherit versionator eutils gnome2
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=dev-python/pygtk-2.10.3
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}