summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:21:04 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 23:21:04 +0000
commit7b7f2919e567d6683fb97420a5f2b2a81067a0fb (patch)
tree7bc6e4da90064f182f39ad8f3aa7957897b84923 /dev-python/gnome-python-desktop-base
parentNew version for GNOME 2.28. (diff)
downloadgentoo-2-7b7f2919e567d6683fb97420a5f2b2a81067a0fb.tar.gz
gentoo-2-7b7f2919e567d6683fb97420a5f2b2a81067a0fb.tar.bz2
gentoo-2-7b7f2919e567d6683fb97420a5f2b2a81067a0fb.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gnome-python-desktop-base')
-rw-r--r--dev-python/gnome-python-desktop-base/ChangeLog8
-rw-r--r--dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.28.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/gnome-python-desktop-base/ChangeLog b/dev-python/gnome-python-desktop-base/ChangeLog
index 5f3b6851ede3..91b3e52ba6d3 100644
--- a/dev-python/gnome-python-desktop-base/ChangeLog
+++ b/dev-python/gnome-python-desktop-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-desktop-base
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.21 2009/10/24 16:16:22 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/ChangeLog,v 1.22 2009/10/29 23:21:04 eva Exp $
+
+*gnome-python-desktop-base-2.28.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-python-desktop-base-2.28.0.ebuild:
+ New version for GNOME 2.28.
24 Oct 2009; nixnut <nixnut@gentoo.org>
gnome-python-desktop-base-2.26.0.ebuild:
diff --git a/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.28.0.ebuild b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.28.0.ebuild
new file mode 100644
index 000000000000..4b3338464d29
--- /dev/null
+++ b/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.28.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-desktop-base/gnome-python-desktop-base-2.28.0.ebuild,v 1.1 2009/10/29 23:21:04 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 versionator
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+MY_PN="gnome-python-desktop"
+PVP="$(get_version_component_range 1-2)"
+
+DESCRIPTION="Provides python the base files for the Gnome Python Desktop bindings"
+HOMEPAGE="http://pygtk.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+# From the gnome-python-desktop eclass
+RDEPEND="virtual/python
+ >=dev-python/pygtk-2.10.3
+ >=dev-libs/glib-2.6.0
+ >=x11-libs/gtk+-2.4.0
+ !<dev-python/gnome-python-extras-2.13
+ !<dev-python/gnome-python-desktop-2.22.0-r10"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.7"
+
+RESTRICT="test"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+}