summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2007-10-12 13:25:35 +0000
committerRémi Cardona <remi@gentoo.org>2007-10-12 13:25:35 +0000
commitfbc44274046abe8822f108c0ec94c309cdb13281 (patch)
tree134bacb003415a52fb337eb427ec683d56d4b87c /dev-python/gnome-python-extras
parentadd gnome-python-extras to package.mask for Gnome 2.20 (diff)
downloadgentoo-2-fbc44274046abe8822f108c0ec94c309cdb13281.tar.gz
gentoo-2-fbc44274046abe8822f108c0ec94c309cdb13281.tar.bz2
gentoo-2-fbc44274046abe8822f108c0ec94c309cdb13281.zip
New version for Gnome 2.20
(Portage version: 2.1.3.12)
Diffstat (limited to 'dev-python/gnome-python-extras')
-rw-r--r--dev-python/gnome-python-extras/ChangeLog9
-rw-r--r--dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.19.1-r13
-rw-r--r--dev-python/gnome-python-extras/files/gnome-python-extras-2.19.1-use_python_config.patch18
-rw-r--r--dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild74
4 files changed, 103 insertions, 1 deletions
diff --git a/dev-python/gnome-python-extras/ChangeLog b/dev-python/gnome-python-extras/ChangeLog
index 62e13554d3e3..c37c5b15b8f3 100644
--- a/dev-python/gnome-python-extras/ChangeLog
+++ b/dev-python/gnome-python-extras/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/gnome-python-extras
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.61 2007/09/15 19:25:27 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/ChangeLog,v 1.62 2007/10/12 13:25:34 remi Exp $
+
+*gnome-python-extras-2.19.1-r1 (12 Oct 2007)
+
+ 12 Oct 2007; Rémi Cardona <remi@gentoo.org>
+ +files/gnome-python-extras-2.19.1-use_python_config.patch,
+ +gnome-python-extras-2.19.1-r1.ebuild:
+ New version for Gnome 2.20
15 Sep 2007; Gilles Dartiguelongue <eva@gentoo.org>
gnome-python-extras-2.14.2-r1.ebuild:
diff --git a/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.19.1-r1 b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.19.1-r1
new file mode 100644
index 000000000000..b3d617a6a431
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/digest-gnome-python-extras-2.19.1-r1
@@ -0,0 +1,3 @@
+MD5 08896c63d71ce44d20fafbaf9c0edc78 gnome-python-extras-2.19.1.tar.bz2 361721
+RMD160 1dd556def13b6cd10ef9a3a747e73ea38ee70e62 gnome-python-extras-2.19.1.tar.bz2 361721
+SHA256 c5f74f4c46dbb379d119d6f74ca4a47653af251bea176dc7a0ecacccb88339f0 gnome-python-extras-2.19.1.tar.bz2 361721
diff --git a/dev-python/gnome-python-extras/files/gnome-python-extras-2.19.1-use_python_config.patch b/dev-python/gnome-python-extras/files/gnome-python-extras-2.19.1-use_python_config.patch
new file mode 100644
index 000000000000..f5e25ea53259
--- /dev/null
+++ b/dev-python/gnome-python-extras/files/gnome-python-extras-2.19.1-use_python_config.patch
@@ -0,0 +1,18 @@
+diff -urNad gnome-python-extras-2.14.3~/acinclude.m4 gnome-python-extras-2.14.3/acinclude.m4
+--- gnome-python-extras-2.14.3~/acinclude.m4 2007-01-20 15:50:13.000000000 +0100
++++ gnome-python-extras-2.14.3/acinclude.m4 2007-05-21 16:39:51.000000000 +0200
+@@ -45,10 +45,14 @@
+ dnl deduce PYTHON_INCLUDES
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
++if test -x "$PYTHON-config"; then
++PYTHON_INCLUDES=`$PYTHON-config --includes 2>/dev/null`
++else
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+ if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ fi
++fi
+ AC_SUBST(PYTHON_INCLUDES)
+ dnl check if the headers exist:
+ save_CPPFLAGS="$CPPFLAGS"
diff --git a/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild b/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild
new file mode 100644
index 000000000000..f8b7d6dbe0cf
--- /dev/null
+++ b/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-extras/gnome-python-extras-2.19.1-r1.ebuild,v 1.1 2007/10/12 13:25:34 remi Exp $
+
+inherit eutils gnome2 python virtualx
+
+DESCRIPTION="GNOME 2 Bindings for Python"
+HOMEPAGE="http://www.pygtk.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc firefox seamonkey xulrunner"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.6
+ >=dev-python/gnome-python-2.10
+ >=dev-python/pygtk-2.4
+ =gnome-extra/gtkhtml-2*
+ xulrunner? ( net-libs/xulrunner )
+ !xulrunner? ( firefox? ( >=www-client/mozilla-firefox-1.0 ) )
+ !xulrunner? ( !firefox? ( seamonkey? ( >=www-client/seamonkey-1.0 ) ) )
+ =gnome-extra/libgda-1*
+ >=app-text/gtkspell-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ # only controls linking, can't disable w/o a patch :)
+ if use xulrunner; then
+ G2CONF="${G2CONF} --with-gtkmozembed=xulrunner"
+ elif use firefox; then
+ G2CONF="${G2CONF} --with-gtkmozembed=firefox"
+ elif use seamonkey; then
+ G2CONF="${G2CONF} --with-gtkmozembed=seamonkey"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # change mozilla to seamonkey
+ sed -i -e 's:1.2b):1.0.0):;s:mozilla):seamonkey):' configure.ac
+
+ epatch "${FILESDIR}/${P}-use_python_config.patch"
+
+ eautoreconf
+}
+
+src_test() {
+ Xmake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0"
+}