summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-24 17:02:42 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-24 17:02:42 +0000
commit69b5fdd43d58c13512aadc54b2c8231fcc99870e (patch)
treedc612305d1fcd2c640b1522711e26bf676cf51b9 /dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild
parentfix pyc/pyo cleanup, fix pygtk.{py,pth} conflicts when installing pygtk-2.0 ... (diff)
downloadgentoo-2-69b5fdd43d58c13512aadc54b2c8231fcc99870e.tar.gz
gentoo-2-69b5fdd43d58c13512aadc54b2c8231fcc99870e.tar.bz2
gentoo-2-69b5fdd43d58c13512aadc54b2c8231fcc99870e.zip
ixed pyc/pyo cleanup issue. removed pygtk installs from gnome-python-1.4 and add depend for pygtk-0.6. cleanup opengl dependencies.
Diffstat (limited to 'dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild')
-rw-r--r--dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild b/dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..11b8ad8fb9bb
--- /dev/null
+++ b/dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python/gnome-python-1.4.4-r1.ebuild,v 1.1 2004/01/24 17:02:42 liquidx Exp $
+
+inherit gnome.org python
+
+DESCRIPTION="GNOME1 Python Bindings"
+HOMEPAGE="http://www.daa.com.au/~james/gnome/"
+
+IUSE=""
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+
+DEPEND="virtual/python
+ =x11-libs/gtk+-1.2*
+ =dev-python/pygtk-0.6*
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ <gnome-base/libglade-1.90.0
+ <gnome-base/control-center-1.90.0"
+
+src_unpack() {
+ unpack ${A}
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+}
+
+src_compile() {
+ CFLAGS="${CFLAGS} `gnome-config capplet --cflags`" \
+ econf
+
+ cd ${S}/pygnome
+ emake || die
+}
+
+src_install() {
+ dodoc AUTHORS COPYING* ChangeLog NEWS MAPPING
+ dodoc README*
+ cd ${S}/pygnome
+ make prefix=${D}/usr datadir=${D}/usr/share install || die " install failed"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/gtk-1.2/gnome
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}