summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-03 19:45:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-03 19:45:28 +0000
commita3150e99a55f5df71188b761be77f00a0d748ed6 (patch)
tree3892e382dd3870a22a6f977966c4b2e4b1c84aac /dev-python/html5lib
parentFix build with --as-needed, see bug #256521. (diff)
downloadgentoo-2-a3150e99a55f5df71188b761be77f00a0d748ed6.tar.gz
gentoo-2-a3150e99a55f5df71188b761be77f00a0d748ed6.tar.bz2
gentoo-2-a3150e99a55f5df71188b761be77f00a0d748ed6.zip
Initial import. Ebuild based on #202456 with minor tweaks. Thanks to Sebastian Wiesner and Priit Laes
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog11
-rw-r--r--dev-python/html5lib/html5lib-0.11.1.ebuild39
-rw-r--r--dev-python/html5lib/metadata.xml5
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
new file mode 100644
index 000000000000..41b799215f7f
--- /dev/null
+++ b/dev-python/html5lib/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/html5lib
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.1 2009/02/03 19:45:28 patrick Exp $
+
+*html5lib-0.11.1 (03 Feb 2009)
+
+ 03 Feb 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +html5lib-0.11.1.ebuild:
+ Initial import. Ebuild based on #202456 with minor tweaks. Thanks to
+ Sebastian Wiesner and Priit Laes
+
diff --git a/dev-python/html5lib/html5lib-0.11.1.ebuild b/dev-python/html5lib/html5lib-0.11.1.ebuild
new file mode 100644
index 000000000000..326158bd9117
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-0.11.1.ebuild,v 1.1 2009/02/03 19:45:28 patrick Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.4"
+
+inherit distutils
+
+DESCRIPTION="HTML parser based on the WHAT-WG Web Applications 1.0 HTML5 specification"
+HOMEPAGE="http://code.google.com/p/html5lib/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+# simplejson will be bundled with python 2.6
+RDEPEND="
+ test? ( dev-python/simplejson )"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6_rc5
+ dev-lang/python[xml]"
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ $(find examples -name '*.pyc' -exec rm -rf {} \;)
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Failed to install examples"
+ fi
+}
+
+src_test() {
+ distutils_python_version
+ "${python}" setup.py test || die "tests failed"
+}
diff --git a/dev-python/html5lib/metadata.xml b/dev-python/html5lib/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/html5lib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>