summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-12-20 07:35:45 +0000
committerTim Harder <radhermit@gentoo.org>2012-12-20 07:35:45 +0000
commit7e514fc1dcdfb2cac9ecc0bfaa2a28790ae22758 (patch)
tree52eeb123cb089b3c4495ab596b78b0f328cd2a48 /dev-python/httplib2
parentVersion bump. Add ruby19. (diff)
downloadgentoo-2-7e514fc1dcdfb2cac9ecc0bfaa2a28790ae22758.tar.gz
gentoo-2-7e514fc1dcdfb2cac9ecc0bfaa2a28790ae22758.tar.bz2
gentoo-2-7e514fc1dcdfb2cac9ecc0bfaa2a28790ae22758.zip
Version bump. Migrate to distutils-r1.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/ChangeLog7
-rw-r--r--dev-python/httplib2/httplib2-0.7.7.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/httplib2/ChangeLog b/dev-python/httplib2/ChangeLog
index 02cab55c95d9..ed11e09e4848 100644
--- a/dev-python/httplib2/ChangeLog
+++ b/dev-python/httplib2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/httplib2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.30 2012/09/21 12:22:44 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/ChangeLog,v 1.31 2012/12/20 07:35:45 radhermit Exp $
+
+*httplib2-0.7.7 (20 Dec 2012)
+
+ 20 Dec 2012; Tim Harder <radhermit@gentoo.org> +httplib2-0.7.7.ebuild:
+ Version bump. Migrate to distutils-r1.
*httplib2-0.7.6 (21 Sep 2012)
diff --git a/dev-python/httplib2/httplib2-0.7.7.ebuild b/dev-python/httplib2/httplib2-0.7.7.ebuild
new file mode 100644
index 000000000000..ba44b496d89f
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.7.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/httplib2/httplib2-0.7.7.ebuild,v 1.1 2012/12/20 07:35:45 radhermit Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="http://code.google.com/p/httplib2/ http://pypi.python.org/pypi/httplib2"
+SRC_URI="http://httplib2.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-macos ~x86-linux"
+IUSE=""
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+python_test() {
+ if [[ ${EPYTHON} == python2.* ]] ; then
+ cd python2
+ else
+ cd python3
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}