summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-12-10 12:20:04 +0000
committerIan Delaney <idella4@gentoo.org>2012-12-10 12:20:04 +0000
commit5097f4546ad57bb5012f746907ef248234d0ddb3 (patch)
tree45e9c05d0acb97a37d04e4197eb011bc4afecb12 /dev-python/kombu
parentVersion bump. (diff)
downloadgentoo-2-5097f4546ad57bb5012f746907ef248234d0ddb3.tar.gz
gentoo-2-5097f4546ad57bb5012f746907ef248234d0ddb3.tar.bz2
gentoo-2-5097f4546ad57bb5012f746907ef248234d0ddb3.zip
Improved 'variation on the theme' to build docs avoiding use of die with python3, prompted by Arfrever wrt initial Bug #445688
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/ChangeLog6
-rw-r--r--dev-python/kombu/kombu-2.4.10.ebuild34
2 files changed, 17 insertions, 23 deletions
diff --git a/dev-python/kombu/ChangeLog b/dev-python/kombu/ChangeLog
index f579905d598f..0bb155ff0b9a 100644
--- a/dev-python/kombu/ChangeLog
+++ b/dev-python/kombu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/kombu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.12 2012/12/08 13:04:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.13 2012/12/10 12:20:04 idella4 Exp $
+
+ 11 Dec 2012; Ian Delaney <idella4@gentoo.org> kombu-2.4.10.ebuild:
+ Improved 'variation on the theme' to build docs avoiding use of die with
+ python3, prompted by Arfrever wrt initial Bug #445688
09 Dec 2012; Ian Delaney <idella4@gentoo.org> kombu-2.4.10.ebuild:
USE doc with python3 set to die due to inability of py3 to build docs, fixed
diff --git a/dev-python/kombu/kombu-2.4.10.ebuild b/dev-python/kombu/kombu-2.4.10.ebuild
index a0cdca3efc84..742d23922761 100644
--- a/dev-python/kombu/kombu-2.4.10.ebuild
+++ b/dev-python/kombu/kombu-2.4.10.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.4.10.ebuild,v 1.2 2012/12/08 13:04:31 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.4.10.ebuild,v 1.3 2012/12/10 12:20:04 idella4 Exp $
EAPI="4"
PYTHON_TESTS_RESTRICTED_ABIS="3.* 2.7-pypy-*"
PYTHON_DEPEND="*:2.7"
-RESTRICT_PYTHON_ABIS="2.[4-6]"
+RESTRICT_PYTHON_ABIS="2.[56]"
SUPPORT_PYTHON_ABIS="1"
DISTUTILS_SRC_TEST="nosetests"
@@ -38,29 +38,19 @@ DEPEND="${RDEPEND}
dev-python/couchdb-python )
dev-python/setuptools"
-src_prepare() {
- CheckDoc() {
- if [[ "$(python_get_version --major)" == '3' ]] && use doc; then
- eerror ""
- eerror "Python3 ***CANNOT*** build the docs for this package"
- error "due to a dependency on django, which does not support python3"
- eerror "Docs can be built effectively with python2."
- eerror "Prepend with USE_PYTHON=2.7 and recommence emerge"
- eerror ""
- die
- fi
- }
- python_execute_function CheckDoc
- distutils_src_prepare
-}
-
src_compile() {
distutils_src_compile
- makedocs() {
- PYTHONPATH="${S}" emake -C docs html
- }
- use doc && python_execute_function makedocs
+ local SPHINXBUILD
+ if use doc; then
+ if python2.7 -c "import django.conf" &> /dev/null; then
+ SPHINXBUILD="sphinx-build-2.7"
+ else
+ die "kombu docs failed installation"
+ fi
+ einfo "building docs for kombu with python2.7"
+ PYTHONPATH="${S}" emake -C docs html SPHINXBUILD="${SPHINXBUILD}"
+ fi
}
src_test() {