summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-12-08 13:04:31 +0000
committerIan Delaney <idella4@gentoo.org>2012-12-08 13:04:31 +0000
commit76c038c0dc607bac16d76c2362f356f4d45ac0a1 (patch)
treefbac4619c5f27301e33964a0f40f64289ee4a05d /dev-python/kombu
parentVersion bump, drop old (diff)
downloadgentoo-2-76c038c0dc607bac16d76c2362f356f4d45ac0a1.tar.gz
gentoo-2-76c038c0dc607bac16d76c2362f356f4d45ac0a1.tar.bz2
gentoo-2-76c038c0dc607bac16d76c2362f356f4d45ac0a1.zip
USE doc with python3 set to die due to inability of py3 to build docs, fixed build of docs with py2, fixes bug #No. 445688 by flameeyes
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/kombu')
-rw-r--r--dev-python/kombu/ChangeLog6
-rw-r--r--dev-python/kombu/kombu-2.4.10.ebuild27
2 files changed, 29 insertions, 4 deletions
diff --git a/dev-python/kombu/ChangeLog b/dev-python/kombu/ChangeLog
index 36d709566e90..f579905d598f 100644
--- a/dev-python/kombu/ChangeLog
+++ b/dev-python/kombu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/kombu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.11 2012/11/29 07:28:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/ChangeLog,v 1.12 2012/12/08 13:04:31 idella4 Exp $
+
+ 09 Dec 2012; Ian Delaney <idella4@gentoo.org> kombu-2.4.10.ebuild:
+ USE doc with python3 set to die due to inability of py3 to build docs, fixed
+ build of docs with py2, fixes bug #No. 445688 by flameeyes
*kombu-2.4.10 (29 Nov 2012)
diff --git a/dev-python/kombu/kombu-2.4.10.ebuild b/dev-python/kombu/kombu-2.4.10.ebuild
index 4f7f8ab6ef2d..a0cdca3efc84 100644
--- a/dev-python/kombu/kombu-2.4.10.ebuild
+++ b/dev-python/kombu/kombu-2.4.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.4.10.ebuild,v 1.1 2012/11/29 07:28:36 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kombu/kombu-2.4.10.ebuild,v 1.2 2012/12/08 13:04:31 idella4 Exp $
EAPI="4"
@@ -33,13 +33,34 @@ DEPEND="${RDEPEND}
dev-python/pymongo
dev-python/msgpack )
doc? ( dev-python/sphinx
+ dev-python/django
dev-python/beanstalkc
dev-python/couchdb-python )
dev-python/setuptools"
+src_prepare() {
+ CheckDoc() {
+ if [[ "$(python_get_version --major)" == '3' ]] && use doc; then
+ eerror ""
+ eerror "Python3 ***CANNOT*** build the docs for this package"
+ error "due to a dependency on django, which does not support python3"
+ eerror "Docs can be built effectively with python2."
+ eerror "Prepend with USE_PYTHON=2.7 and recommence emerge"
+ eerror ""
+ die
+ fi
+ }
+ python_execute_function CheckDoc
+ distutils_src_prepare
+}
+
src_compile() {
distutils_src_compile
- use doc && emake -C docs html
+
+ makedocs() {
+ PYTHONPATH="${S}" emake -C docs html
+ }
+ use doc && python_execute_function makedocs
}
src_test() {
@@ -53,7 +74,7 @@ src_install() {
distutils_src_install
if use examples; then
docompress -x usr/share/doc/${P}/examples/
- insinto usr/share/doc/${P}/
+ insinto usr/share/doc/${PF}/
doins -r examples/
fi
use doc && dohtml -r docs/.build/html/