summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-04 22:29:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-04 22:29:22 +0000
commit130a7cd305c3b76237cdaec55ba002a69c888f7b (patch)
tree562235e5e311dd3a9d2e8192c1cfda58df859f95 /dev-python/logilab-common
parentSet SUPPORT_PYTHON_ABIS. Tests are restricted so remove "test" USE flag. (diff)
downloadgentoo-2-130a7cd305c3b76237cdaec55ba002a69c888f7b.tar.gz
gentoo-2-130a7cd305c3b76237cdaec55ba002a69c888f7b.tar.bz2
gentoo-2-130a7cd305c3b76237cdaec55ba002a69c888f7b.zip
Version bump.
(Portage version: 14182-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog8
-rw-r--r--dev-python/logilab-common/logilab-common-0.43.0.ebuild78
-rw-r--r--dev-python/logilab-common/logilab-common-0.45.0.ebuild88
3 files changed, 95 insertions, 79 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index c91fc87b6322..cee60114a80d 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.44 2009/08/25 14:40:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.45 2009/09/04 22:29:22 arfrever Exp $
+
+*logilab-common-0.45.0 (04 Sep 2009)
+
+ 04 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -logilab-common-0.43.0.ebuild, +logilab-common-0.45.0.ebuild:
+ Version bump.
*logilab-common-0.44.0 (25 Aug 2009)
diff --git a/dev-python/logilab-common/logilab-common-0.43.0.ebuild b/dev-python/logilab-common/logilab-common-0.43.0.ebuild
deleted file mode 100644
index f9109db61be4..000000000000
--- a/dev-python/logilab-common/logilab-common-0.43.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.43.0.ebuild,v 1.1 2009/07/24 21:48:43 arfrever Exp $
-
-EAPI="2"
-
-inherit distutils eutils python
-
-DESCRIPTION="useful miscellaneous modules used by Logilab projects"
-HOMEPAGE="http://www.logilab.org/projects/common/"
-SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="test"
-
-DEPEND="test? ( dev-python/egenix-mx-base )"
-RDEPEND=""
-
-PYTHON_MODNAME="logilab"
-# Extra documentation (html/pdf) needs some love
-
-src_prepare() {
- distutils_src_prepare
-
- epatch "${FILESDIR}/${PN}-0.41.0-remove-broken-tests.patch"
-}
-
-src_test() {
- python_version
-
- # Install temporarily.
- local tpath="${T}/test"
- local lpath="${tpath}/lib/python"
-
- # setuptools would fail if the directory doesn't exist.
- mkdir -p "${lpath}" || die
-
- # We also have to add ${lpath} to PYTHONPATH else the installation would
- # fail.
- PYTHONPATH="${lpath}" ${python} setup.py install --home="${tpath}" || \
- die "test copy failed"
-
- # Get a rid of precompiled files to ensure we run our _modified_ tests
- find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
-
- # Remove a botched tests.
- # To support test w/o setuptools.
- if [[ -d "${lpath}/${PN/-//}" ]]; then
- pushd "${lpath}/${PN/-//}" >/dev/null || die
- else
- pushd "${lpath}/${P/-/_}-py${PYVER}.egg/${PN/-//}" >/dev/null || die
- fi
-
- # Bug 223079
- if [[ "${EUID}" -eq 0 ]]; then
- rm test/unittest_fileutils.py || die
- fi
-
- popd >/dev/null || die
-
- # It picks up the tests relative to the current dir, so cd in. Do
- # not cd in too far though (to logilab/common for example) or some
- # relative/absolute module location tests fail.
- pushd "${lpath}" >/dev/null || die
- PYTHONPATH="${lpath}" ${python} "${tpath}/bin/pytest" -v || die "tests failed"
- popd >/dev/null || die
-}
-
-src_install() {
- distutils_src_install
-
- doman doc/pytest.1 || die "doman failed"
-
- # Remove unittests since they're just needed during build-time
- rm -rf "${D}/$(python_get_sitedir)/${PN/-//}/test" || die
-}
diff --git a/dev-python/logilab-common/logilab-common-0.45.0.ebuild b/dev-python/logilab-common/logilab-common-0.45.0.ebuild
new file mode 100644
index 000000000000..69473e9cf97b
--- /dev/null
+++ b/dev-python/logilab-common/logilab-common-0.45.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.45.0.ebuild,v 1.1 2009/09/04 22:29:22 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils python
+
+DESCRIPTION="useful miscellaneous modules used by Logilab projects"
+HOMEPAGE="http://www.logilab.org/projects/common/"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-python/egenix-mx-base )"
+RDEPEND=""
+
+RESTRICT_PYTHON_ABIS="3*"
+
+PYTHON_MODNAME="logilab"
+# Extra documentation (html/pdf) needs some love
+
+pkg_setup() {
+ # Tests using dev-python/psycopg are skipped when dev-python/psycopg isn't installed.
+ if use test && has_version dev-python/psycopg && ! has_version dev-python/psycopg[mxdatetime]; then
+ die "dev-python/psycopg should be installed with USE=\"mxdatetime\""
+ fi
+}
+
+src_prepare() {
+ distutils_src_prepare
+
+ epatch "${FILESDIR}/${PN}-0.41.0-remove-broken-tests.patch"
+}
+
+src_test() {
+ testing() {
+ # Install temporarily.
+ local tpath="${T}/test-${PYTHON_ABI}"
+ local lpath="${tpath}/lib/python"
+
+ # setuptools would fail if the directory doesn't exist.
+ mkdir -p "${lpath}" || die
+
+ # We also have to add ${lpath} to PYTHONPATH else the installation would
+ # fail.
+ PYTHONPATH="${lpath}" "$(PYTHON)" setup.py build -b "build-${PYTHON_ABI}" install --home="${tpath}" || die "test copy failed"
+
+ # Get a rid of precompiled files to ensure we run our _modified_ tests
+ find ${lpath} -type f -name '*.pyc' -exec rm {} ';'
+
+ # Remove a botched tests.
+ # To support test w/o setuptools.
+ if [[ -d "${lpath}/${PN/-//}" ]]; then
+ pushd "${lpath}/${PN/-//}" >/dev/null || die
+ else
+ pushd "${lpath}/${P/-/_}-py${PYTHON_ABI}.egg/${PN/-//}" >/dev/null || die
+ fi
+
+ # Bug 223079
+ if [[ "${EUID}" -eq 0 ]]; then
+ rm test/unittest_fileutils.py || die
+ fi
+
+ popd >/dev/null || die
+
+ # It picks up the tests relative to the current dir, so cd in. Do
+ # not cd in too far though (to logilab/common for example) or some
+ # relative/absolute module location tests fail.
+ pushd "${lpath}" >/dev/null || die
+ PYTHONPATH="${lpath}" "$(PYTHON)" "${tpath}/bin/pytest" -v || die "tests failed"
+ popd >/dev/null || die
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ doman doc/pytest.1 || die "doman failed"
+
+ # Remove unittests since they're just needed during build-time
+ rm -rf "${D}"usr/lib*/python*/site-packages/${PN/-//}/test || die
+}