summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-02 12:21:44 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-02 12:21:44 +0000
commit93e9a22adfc15b4c32920bb9a742cb418414ded8 (patch)
treeae0ada6cbb89c969d0e16eb862d3ae942258211d /dev-python/logilab-common
parentFix download URI, bug #492982. (diff)
downloadgentoo-2-93e9a22adfc15b4c32920bb9a742cb418414ded8.tar.gz
gentoo-2-93e9a22adfc15b4c32920bb9a742cb418414ded8.tar.bz2
gentoo-2-93e9a22adfc15b4c32920bb9a742cb418414ded8.zip
Fix test invocation to write to TEST_DIR rather than BUILD_DIR.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog6
-rw-r--r--dev-python/logilab-common/logilab-common-0.59.1.ebuild4
-rw-r--r--dev-python/logilab-common/logilab-common-0.60.0.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index 448132751677..a2483c2fd3a5 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.131 2013/09/05 18:46:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.132 2013/12/02 12:21:44 mgorny Exp $
+
+ 02 Dec 2013; Michał Górny <mgorny@gentoo.org> logilab-common-0.59.1.ebuild,
+ logilab-common-0.60.0.ebuild:
+ Fix test invocation to write to TEST_DIR rather than BUILD_DIR.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> logilab-common-0.59.1.ebuild,
logilab-common-0.60.0.ebuild:
diff --git a/dev-python/logilab-common/logilab-common-0.59.1.ebuild b/dev-python/logilab-common/logilab-common-0.59.1.ebuild
index 0ccc98b05c11..98336739c3c3 100644
--- a/dev-python/logilab-common/logilab-common-0.59.1.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.59.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.1.ebuild,v 1.5 2013/09/05 18:46:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.1.ebuild,v 1.6 2013/12/02 12:21:44 mgorny Exp $
EAPI=5
# broken with python3.3, bug #449276
@@ -58,7 +58,7 @@ python_test() {
export TZ=UTC
# Make sure that the tests use correct modules.
- pushd "${BUILD_DIR}"/lib > /dev/null || die
+ pushd "${TEST_DIR}"/lib > /dev/null || die
"${TEST_DIR}"/scripts/pytest || die "Tests fail with ${EPYTHON}"
popd > /dev/null || die
}
diff --git a/dev-python/logilab-common/logilab-common-0.60.0.ebuild b/dev-python/logilab-common/logilab-common-0.60.0.ebuild
index 798e22ec4b69..3d609ff5b6a5 100644
--- a/dev-python/logilab-common/logilab-common-0.60.0.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.60.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.60.0.ebuild,v 1.3 2013/09/05 18:46:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.60.0.ebuild,v 1.4 2013/12/02 12:21:44 mgorny Exp $
EAPI=5
@@ -63,7 +63,7 @@ python_test() {
export TZ=UTC
# Make sure that the tests use correct modules.
- pushd "${BUILD_DIR}"/lib > /dev/null || die
+ pushd "${TEST_DIR}"/lib > /dev/null || die
"${TEST_DIR}"/scripts/pytest || die "Tests fail with ${EPYTHON}"
popd > /dev/null || die
}