summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-06-25 02:54:28 +0000
committerMike Gilbert <floppym@gentoo.org>2013-06-25 02:54:28 +0000
commitf52f7de8ce53f8946a1e50345c30201f9e3d9a71 (patch)
tree2c6d3530ee04bf9bc285007b2888f451605179d5 /dev-python/logilab-common
parentRemove mask for oyranos-0.9.4 (diff)
downloadgentoo-2-f52f7de8ce53f8946a1e50345c30201f9e3d9a71.tar.gz
gentoo-2-f52f7de8ce53f8946a1e50345c30201f9e3d9a71.tar.bz2
gentoo-2-f52f7de8ce53f8946a1e50345c30201f9e3d9a71.zip
Apply 'zipsafe' patch to make test install behave consistently. Drop python3.3 support, bug 449276.
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/ChangeLog7
-rw-r--r--dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch13
-rw-r--r--dev-python/logilab-common/logilab-common-0.59.1.ebuild13
3 files changed, 29 insertions, 4 deletions
diff --git a/dev-python/logilab-common/ChangeLog b/dev-python/logilab-common/ChangeLog
index 4727f4f0fe3c..526ee966bbd9 100644
--- a/dev-python/logilab-common/ChangeLog
+++ b/dev-python/logilab-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/logilab-common
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.125 2013/06/18 14:55:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/ChangeLog,v 1.126 2013/06/25 02:54:28 floppym Exp $
+
+ 25 Jun 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/logilab-common-0.59.1-zipsafe.patch, logilab-common-0.59.1.ebuild:
+ Apply 'zipsafe' patch to make test install behave consistently. Drop python3.3
+ support, bug 449276.
18 Jun 2013; Ian Delaney <idella4@gentoo.org> logilab-common-0.59.1.ebuild:
add py3.3 support
diff --git a/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch b/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch
new file mode 100644
index 000000000000..6807c5544c83
--- /dev/null
+++ b/dev-python/logilab-common/files/logilab-common-0.59.1-zipsafe.patch
@@ -0,0 +1,13 @@
+Make sure setuptools does not create a zip file in python_test; this is buggy
+and causes tests to fail.
+
+--- a/setup.py
++++ b/setup.py
+@@ -179,6 +179,7 @@
+ ext_modules = ext_modules,
+ cmdclass = {'install_lib': MyInstallLib,
+ 'build_py': MyBuildPy},
++ zip_safe = False,
+ **kwargs
+ )
+
diff --git a/dev-python/logilab-common/logilab-common-0.59.1.ebuild b/dev-python/logilab-common/logilab-common-0.59.1.ebuild
index d339be0eb555..25213365c549 100644
--- a/dev-python/logilab-common/logilab-common-0.59.1.ebuild
+++ b/dev-python/logilab-common/logilab-common-0.59.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.1.ebuild,v 1.2 2013/06/18 14:55:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logilab-common/logilab-common-0.59.1.ebuild,v 1.3 2013/06/25 02:54:28 floppym Exp $
EAPI=5
# broken with python3.3, bug #449276
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_COMPAT=( python{2_6,2_7,3_2} pypy{1_9,2_0} )
inherit distutils-r1 eutils
@@ -31,6 +31,12 @@ DEPEND="${RDEPEND}
)
doc? ( dev-python/epydoc )"
+PATCHES=(
+ # Make sure setuptools does not create a zip file in python_test;
+ # this is buggy and causes tests to fail.
+ "${FILESDIR}/${PN}-0.59.1-zipsafe.patch"
+)
+
python_prepare_all() {
sed -e 's:(CURDIR):{S}/${P}:' -i doc/makefile || die
distutils-r1_python_prepare_all
@@ -52,8 +58,9 @@ python_test() {
export TZ=UTC
# Make sure that the tests use correct modules.
- cd "${TEST_DIR}"/lib || die
+ pushd "${BUILD_DIR}"/lib > /dev/null || die
"${TEST_DIR}"/scripts/pytest || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null || die
}
python_install_all() {