summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-09 22:10:03 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-09 22:10:03 +0000
commitb8f300defde5550545ba9916901c5a939550c8df (patch)
treeb4d360ee1b703c3dc713ebda444b4e8d357c963c /dev-python/matplotlib
parentdev-tcltk/itcl: Version Bump (diff)
downloadgentoo-2-b8f300defde5550545ba9916901c5a939550c8df.tar.gz
gentoo-2-b8f300defde5550545ba9916901c5a939550c8df.tar.bz2
gentoo-2-b8f300defde5550545ba9916901c5a939550c8df.zip
dev-python/matplotlib: Restrict py3.3 as numpy is restricted here; use github mirror definition
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/ChangeLog6
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild6
-rw-r--r--dev-python/matplotlib/matplotlib-1.2.0.ebuild6
-rw-r--r--dev-python/matplotlib/metadata.xml14
4 files changed, 18 insertions, 14 deletions
diff --git a/dev-python/matplotlib/ChangeLog b/dev-python/matplotlib/ChangeLog
index 74bf46a4171e..d4278757f03c 100644
--- a/dev-python/matplotlib/ChangeLog
+++ b/dev-python/matplotlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/matplotlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.134 2013/01/07 05:45:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/ChangeLog,v 1.135 2013/01/09 22:10:03 jlec Exp $
+
+ 09 Jan 2013; Justin Lecher <jlec@gentoo.org> matplotlib-1.2.0.ebuild,
+ matplotlib-1.2.0-r1.ebuild, metadata.xml:
+ Restrict py3.3 as numpy is restricted here; use github mirror definition
07 Jan 2013; Ian Delaney <idella4@gentoo.org> matplotlib-1.0.1-r1.ebuild,
matplotlib-1.1.0.ebuild, matplotlib-1.1.1.ebuild, matplotlib-1.2.0-r1.ebuild,
diff --git a/dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild b/dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild
index 8dbd87ee8564..3a3972d54371 100644
--- a/dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild,v 1.3 2013/01/06 19:20:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0-r1.ebuild,v 1.4 2013/01/09 22:10:03 jlec Exp $
EAPI="3"
@@ -8,7 +8,7 @@ PYTHON_DEPEND="*:2.6"
PYTHON_USE_WITH="tk"
PYTHON_USE_WITH_OPT="tk"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+RESTRICT_PYTHON_ABIS="3.3 *-jython 2.7-pypy-*"
PYTHON_TESTS_RESTRICTED_ABIS="2.[56] 3.1"
DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing" "3.* + -fno-strict-aliasing")
@@ -21,7 +21,7 @@ inherit distutils eutils
DESCRIPTION="Pure python plotting library with matlab like syntax"
HOMEPAGE="http://matplotlib.org/ http://pypi.python.org/pypi/matplotlib"
-SRC_URI="https://github.com/downloads/${PN}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
IUSE="cairo doc excel examples fltk gtk gtk3 latex qt4 test tk wxwidgets"
SLOT="0"
diff --git a/dev-python/matplotlib/matplotlib-1.2.0.ebuild b/dev-python/matplotlib/matplotlib-1.2.0.ebuild
index 497491298b6b..c5137d0bf396 100644
--- a/dev-python/matplotlib/matplotlib-1.2.0.ebuild
+++ b/dev-python/matplotlib/matplotlib-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0.ebuild,v 1.5 2013/01/06 19:20:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/matplotlib/matplotlib-1.2.0.ebuild,v 1.6 2013/01/09 22:10:03 jlec Exp $
EAPI="3"
@@ -8,7 +8,7 @@ PYTHON_DEPEND="*:2.6"
PYTHON_USE_WITH="tk"
PYTHON_USE_WITH_OPT="tk"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
+RESTRICT_PYTHON_ABIS="3.3 *-jython 2.7-pypy-*"
PYTHON_TESTS_RESTRICTED_ABIS="2.[56] 3.1"
PYTHON_CFLAGS=("2.* + -fno-strict-aliasing" "3.* + -fno-strict-aliasing")
PYTHON_CXXFLAGS=("2.* + -fno-strict-aliasing" "3.* + -fno-strict-aliasing")
@@ -20,7 +20,7 @@ inherit distutils eutils
DESCRIPTION="Pure python plotting library with matlab like syntax"
HOMEPAGE="http://matplotlib.org/ http://pypi.python.org/pypi/matplotlib"
-SRC_URI="https://github.com/downloads/${PN}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://github/${PN}/${PN}/${P}.tar.gz"
IUSE="cairo doc excel examples fltk gtk latex qt4 test tk wxwidgets"
SLOT="0"
diff --git a/dev-python/matplotlib/metadata.xml b/dev-python/matplotlib/metadata.xml
index b6bcdd76c38b..d5fb8ef9b284 100644
--- a/dev-python/matplotlib/metadata.xml
+++ b/dev-python/matplotlib/metadata.xml
@@ -1,16 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<longdescription lang="en">
+ <herd>python</herd>
+ <longdescription lang="en">
matplotlib is an interactive library for plotting and doing basic
data analysis in python with a syntax similar to matlab. It provides a
variety of backends and hard copy formats for almost ready publication plots.
</longdescription>
-<use>
- <flag name='excel'>Pull <pkg>dev-python/xlwt</pkg> for the exceltools toolkit</flag>
- <flag name='traits'>Pull <pkg>dev-python/traits</pkg> for the
+ <use>
+ <flag name="excel">Pull <pkg>dev-python/xlwt</pkg> for the exceltools toolkit</flag>
+ <flag name="traits">Pull <pkg>dev-python/traits</pkg> for the
experimental enthought traits support</flag>
- <flag name='gtk3'>Use <pkg>x11-libs/gtk+:3</pkg> instead of <pkg>x11-libs/gtk+:2</pkg></flag>
-</use>
+ <flag name="gtk3">Use <pkg>x11-libs/gtk+:3</pkg> instead of <pkg>x11-libs/gtk+:2</pkg></flag>
+ </use>
</pkgmetadata>