summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 12:05:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 12:05:11 +0000
commit7f9c4f01eb0fed7cf7536d85ac3fdaab297ac16f (patch)
tree93b845f2feb3b8a8e03b28b4d09b226c76bd6d86 /dev-python/mechanize
parentamd64/x86 stable, bug #258529 (diff)
downloadgentoo-2-7f9c4f01eb0fed7cf7536d85ac3fdaab297ac16f.tar.gz
gentoo-2-7f9c4f01eb0fed7cf7536d85ac3fdaab297ac16f.tar.bz2
gentoo-2-7f9c4f01eb0fed7cf7536d85ac3fdaab297ac16f.zip
Bump to 0.1.11, fixes #258427
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mechanize')
-rw-r--r--dev-python/mechanize/ChangeLog9
-rw-r--r--dev-python/mechanize/mechanize-0.1.11.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-python/mechanize/ChangeLog b/dev-python/mechanize/ChangeLog
index 641a3288c9de..3cb853777f7c 100644
--- a/dev-python/mechanize/ChangeLog
+++ b/dev-python/mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/mechanize
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.10 2008/12/07 10:44:02 patrick Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/ChangeLog,v 1.11 2009/02/15 12:05:11 patrick Exp $
+
+*mechanize-0.1.11 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +mechanize-0.1.11.ebuild:
+ Bump to 0.1.11, fixes #258427
*mechanize-0.1.10 (07 Dec 2008)
diff --git a/dev-python/mechanize/mechanize-0.1.11.ebuild b/dev-python/mechanize/mechanize-0.1.11.ebuild
new file mode 100644
index 000000000000..e65ae6ed6f49
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.1.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mechanize/mechanize-0.1.11.ebuild,v 1.1 2009/02/15 12:05:11 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/clientform-0.2.7"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # use distutils instead of setuptools
+ sed -i \
+ -e 's/not hasattr(sys, "version_info")/1/' \
+ setup.py || die "sed in setup.py failed"
+
+ # We don't run coverage tests or functional_tests
+ # which access the network, just doctests and unit tests
+ sed -i \
+ -e '/import coverage/d' \
+ test.py || die "sed in test.py failed"
+}
+
+src_install() {
+ DOCS="0.1-changes.txt"
+ # remove to prevent distutils_src_install from installing it
+ dohtml *.html
+ rm README.html*
+
+ distutils_src_install
+}
+
+src_test() {
+ PYTHONPATH=build/lib/ "${python}" test.py || die "tests failed"
+}