summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-16 09:31:37 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-16 09:31:37 +0000
commita706fa65d3bf13c1fdb9b372e1cbf3c0951c3a6a (patch)
treef77f7c3d293d535f52ff0795155a760a7f33a4ff /dev-python/medusa/medusa-0.5.3.ebuild
parentversion bump. masking until files propogate on mirrors (diff)
downloadgentoo-2-a706fa65d3bf13c1fdb9b372e1cbf3c0951c3a6a.tar.gz
gentoo-2-a706fa65d3bf13c1fdb9b372e1cbf3c0951c3a6a.tar.bz2
gentoo-2-a706fa65d3bf13c1fdb9b372e1cbf3c0951c3a6a.zip
version bump. masking until files propogate on mirrors
Diffstat (limited to 'dev-python/medusa/medusa-0.5.3.ebuild')
-rw-r--r--dev-python/medusa/medusa-0.5.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/medusa/medusa-0.5.3.ebuild b/dev-python/medusa/medusa-0.5.3.ebuild
new file mode 100644
index 000000000000..cdbbe25bab6e
--- /dev/null
+++ b/dev-python/medusa/medusa-0.5.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/medusa/medusa-0.5.3.ebuild,v 1.1 2003/05/16 09:31:23 liquidx Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="Medusa is a framework for writing long-running, high-performance network servers in Python, using asynchronous sockets"
+HOMEPAGE="http://oedipus.sourceforge.net/medusa/"
+## NOTE: for some reason i get 403 to this URL. must mirror on gentoo
+#SRC_URI="http://www.amk.ca/files/python/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="PYTHON"
+SLOT="0"
+KEYWORDS="-x86"
+DEPEND="virtual/python"
+S=${WORKDIR}/${P}
+
+src_install () {
+ mydoc="CHANGES.txt LICENSE.txt README.txt docs/*.txt"
+ distutils_src_install
+
+ dodir /usr/share/doc/${PF}/example
+ cp -r demo/* ${D}/usr/share/doc/${PF}/example
+ dohtml docs/*.html docs/*.gif
+}