summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-19 12:24:12 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-19 12:24:12 +0000
commitb68915e177ef9e8588207f859ca075c7d4332ddc (patch)
tree44cab214db3e0c76b350882d84a7ccf556d15eb8 /dev-python/meld3/meld3-0.6.9-r1.ebuild
parentmigrate -> distutils-r1, add IUSE doc, html doc install (diff)
downloadgentoo-2-b68915e177ef9e8588207f859ca075c7d4332ddc.tar.gz
gentoo-2-b68915e177ef9e8588207f859ca075c7d4332ddc.tar.bz2
gentoo-2-b68915e177ef9e8588207f859ca075c7d4332ddc.zip
migrate -> distutils-r1, rm 'distutils' ebuild of that version
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/meld3/meld3-0.6.9-r1.ebuild')
-rw-r--r--dev-python/meld3/meld3-0.6.9-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/meld3/meld3-0.6.9-r1.ebuild b/dev-python/meld3/meld3-0.6.9-r1.ebuild
new file mode 100644
index 000000000000..600108ef997c
--- /dev/null
+++ b/dev-python/meld3/meld3-0.6.9-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/meld3/meld3-0.6.9-r1.ebuild,v 1.1 2013/07/19 12:24:12 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="meld3 is an HTML/XML templating engine."
+HOMEPAGE="https://github.com/supervisor/meld3 http://pypi.python.org/pypi/meld3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ "${PYTHON}" ${PN}/test_${PN}.py || die "Tests failed under ${EPYTHON}"
+}