summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 16:09:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 16:09:24 +0000
commit505ce7bba6b2cb51612b6802b6fabe5b9200eb5c (patch)
treeac90a56edd7dac78e45956c056f6a7ee423e4160 /dev-python/mpi4py
parentDelete older ebuild. (diff)
downloadgentoo-2-505ce7bba6b2cb51612b6802b6fabe5b9200eb5c.tar.gz
gentoo-2-505ce7bba6b2cb51612b6802b6fabe5b9200eb5c.tar.bz2
gentoo-2-505ce7bba6b2cb51612b6802b6fabe5b9200eb5c.zip
Version bump.
(Portage version: 2.2_rc86_p1/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/ChangeLog8
-rw-r--r--dev-python/mpi4py/mpi4py-1.2.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/mpi4py/ChangeLog b/dev-python/mpi4py/ChangeLog
index d6bf47a60581..84a8bf767cc7 100644
--- a/dev-python/mpi4py/ChangeLog
+++ b/dev-python/mpi4py/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/mpi4py
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.4 2010/03/05 18:21:36 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.5 2010/09/22 16:09:24 arfrever Exp $
+
+*mpi4py-1.2.2 (22 Sep 2010)
+
+ 22 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -mpi4py-1.2.ebuild, +mpi4py-1.2.2.ebuild:
+ Version bump.
*mpi4py-1.2.1 (05 Mar 2010)
diff --git a/dev-python/mpi4py/mpi4py-1.2.2.ebuild b/dev-python/mpi4py/mpi4py-1.2.2.ebuild
new file mode 100644
index 000000000000..15e9c93bd7ff
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-1.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.2.2.ebuild,v 1.1 2010/09/22 16:09:24 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="http://code.google.com/p/mpi4py/ http://pypi.python.org/pypi/mpi4py"
+SRC_URI="http://mpi4py.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="virtual/mpi"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" mpiexec -n 2 "$(PYTHON)" test/runalltest.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r docs/* || die "doins failed"
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r demo/* || die "doins failed"
+ fi
+}