summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-08-11 16:14:09 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-08-11 16:14:09 +0000
commite6369c76360148f33e580c3bd3a8005ed17c4549 (patch)
tree1ece026a1d748907d9f532b61ee4bc9dc1e8d45f /dev-python/mpi4py
parentremoving ruby21 from 0.5.0 for bug 513284 (diff)
downloadgentoo-2-e6369c76360148f33e580c3bd3a8005ed17c4549.tar.gz
gentoo-2-e6369c76360148f33e580c3bd3a8005ed17c4549.tar.bz2
gentoo-2-e6369c76360148f33e580c3bd3a8005ed17c4549.zip
fix usage of ldshared (bug #514288)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/ChangeLog6
-rw-r--r--dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch24
-rw-r--r--dev-python/mpi4py/mpi4py-1.3.1.ebuild4
3 files changed, 31 insertions, 3 deletions
diff --git a/dev-python/mpi4py/ChangeLog b/dev-python/mpi4py/ChangeLog
index d156b6c096ef..83a9b4c3fdab 100644
--- a/dev-python/mpi4py/ChangeLog
+++ b/dev-python/mpi4py/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/mpi4py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.16 2014/08/11 07:06:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/ChangeLog,v 1.17 2014/08/11 16:14:09 ottxor Exp $
+
+ 11 Aug 2014; Christoph Junghans <ottxor@gentoo.org>
+ +files/mpi4py-1.3.1-ldshared.patch, mpi4py-1.3.1.ebuild:
+ fix usage of ldshared (bug #514288)
11 Aug 2014; Justin Lecher <jlec@gentoo.org> mpi4py-1.3.1.ebuild:
Add python3.4 support
diff --git a/dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch b/dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch
new file mode 100644
index 000000000000..ae1eade0de2d
--- /dev/null
+++ b/dev-python/mpi4py/files/mpi4py-1.3.1-ldshared.patch
@@ -0,0 +1,24 @@
+# HG changeset patch
+# User Christoph Junghans <junghans@votca.org>
+# Date 1407773183 21600
+# Mon Aug 11 10:06:23 2014 -0600
+# Node ID ee313041ba5d7f0706f8140b4e965179e807ef56
+# Parent c66c1be9d40ae69aa61c45572fbe14ef3209378e
+Fix usage of LDSHARED
+
+- LDSHARED contain the linker, too
+- was used as it would only contain the options in the latter part
+- use split_linker_cmd to throw away the linker cmd
+- see https://bugs.gentoo.org/show_bug.cgi?id=514288
+
+diff -r c66c1be9d40a -r ee313041ba5d conf/mpidistutils.py
+--- a/conf/mpidistutils.py Wed Sep 04 22:40:25 2013 +0300
++++ b/conf/mpidistutils.py Mon Aug 11 10:06:23 2014 -0600
+@@ -176,6 +176,7 @@
+ opt = environ.get('OPT', opt )
+ ccshared = environ.get('CCSHARED', ccshared)
+ ldshared = environ.get('LDSHARED', ldshared)
++ _, ldshared = split_linker_cmd(ldshared)
+ cflags = ' '.join((basecflags, opt, cflags))
+ cxxflags = ' '.join((basecflags, opt, cxxflags))
+ cxxflags = cxxflags.replace('-Wstrict-prototypes', '')
diff --git a/dev-python/mpi4py/mpi4py-1.3.1.ebuild b/dev-python/mpi4py/mpi4py-1.3.1.ebuild
index 287335a11836..6e53591afae7 100644
--- a/dev-python/mpi4py/mpi4py-1.3.1.ebuild
+++ b/dev-python/mpi4py/mpi4py-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3.1.ebuild,v 1.3 2014/08/11 07:06:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/mpi4py/mpi4py-1.3.1.ebuild,v 1.4 2014/08/11 16:14:09 ottxor Exp $
EAPI=5
@@ -23,7 +23,7 @@ DEPEND="${RDEPEND}
virtual/mpi[romio] )"
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${P}-py3-test-backport-1.patch )
+PATCHES=( "${FILESDIR}"/${P}-py3-test-backport-1.patch "${FILESDIR}"/${P}-ldshared.patch )
python_prepare_all() {
# not needed on install