summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-18 17:49:03 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-18 17:49:03 +0000
commit686daab64dd8ebccb204f067008a26b7f4f8dc6d (patch)
tree6069cc6bc251826d1e4e3c1308cad05a1a9210f1 /dev-python/nose
parentpunt some now unused entries (diff)
downloadgentoo-2-686daab64dd8ebccb204f067008a26b7f4f8dc6d.tar.gz
gentoo-2-686daab64dd8ebccb204f067008a26b7f4f8dc6d.tar.bz2
gentoo-2-686daab64dd8ebccb204f067008a26b7f4f8dc6d.zip
Version bump.
(Portage version: 2.2.0_alpha9_p3/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/ChangeLog8
-rw-r--r--dev-python/nose/nose-1.0.0.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-python/nose/ChangeLog b/dev-python/nose/ChangeLog
index 94c398064d6b..bb262e8ab88b 100644
--- a/dev-python/nose/ChangeLog
+++ b/dev-python/nose/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/nose
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.62 2010/12/14 19:53:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/ChangeLog,v 1.63 2010/12/18 17:49:03 arfrever Exp $
+
+*nose-1.0.0 (18 Dec 2010)
+
+ 18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +nose-1.0.0.ebuild:
+ Version bump.
14 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
nose-0.11.3.ebuild, nose-0.11.4.ebuild:
diff --git a/dev-python/nose/nose-1.0.0.ebuild b/dev-python/nose/nose-1.0.0.ebuild
new file mode 100644
index 000000000000..e30e54418bd0
--- /dev/null
+++ b/dev-python/nose/nose-1.0.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose/nose-1.0.0.ebuild,v 1.1 2010/12/18 17:49:03 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+# DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+DESCRIPTION="A unittest extension offering automatic test suite discovery and easy test authoring"
+HOMEPAGE="http://somethingaboutorange.com/mrl/projects/nose/ http://code.google.com/p/python-nose/ http://pypi.python.org/pypi/nose https://bitbucket.org/jpellerin/nose/"
+SRC_URI="http://somethingaboutorange.com/mrl/projects/nose/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/setuptools"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )
+ test? ( dev-python/twisted )"
+
+DOCS="AUTHORS"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable tests and doc features that access the network
+ epatch "${FILESDIR}/${PN}-0.10.0-tests-nonetwork.patch"
+ epatch "${FILESDIR}/${PN}-0.11.0-disable_intersphinx.patch"
+
+ # Disable versioning of nosetests script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" -i setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd doc
+ mkdir -p .build/html .build/doctrees
+ sphinx-build . html || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ testing() {
+ # Tests fail with Python 3.
+ # http://code.google.com/p/python-nose/issues/detail?id=387
+ [[ "${PYTHON_ABI}" == 3.* ]] && return
+
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py build -b build-${PYTHON_ABI} test
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install --install-data "${EPREFIX}/usr/share"
+
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/nosetests"
+
+ if use doc; then
+ dohtml -r -A txt doc/html/* || die "Installation of documentation failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}