summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 21:44:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-22 21:44:58 +0000
commit030210b917f29d2788202f14decbd4472ae000a6 (patch)
tree654ba37d250f80c5c64843670bc4faed523f2b88 /dev-python/numarray/numarray-1.5.2-r1.ebuild
parentDelete dev-python/clientform. (diff)
downloadgentoo-2-030210b917f29d2788202f14decbd4472ae000a6.tar.gz
gentoo-2-030210b917f29d2788202f14decbd4472ae000a6.tar.bz2
gentoo-2-030210b917f29d2788202f14decbd4472ae000a6.zip
Delete dev-python/numarray.
Diffstat (limited to 'dev-python/numarray/numarray-1.5.2-r1.ebuild')
-rw-r--r--dev-python/numarray/numarray-1.5.2-r1.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/numarray/numarray-1.5.2-r1.ebuild b/dev-python/numarray/numarray-1.5.2-r1.ebuild
deleted file mode 100644
index b8f5f74fc37a..000000000000
--- a/dev-python/numarray/numarray-1.5.2-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numarray/numarray-1.5.2-r1.ebuild,v 1.15 2010/07/06 14:19:53 arfrever Exp $
-
-inherit eutils distutils
-
-DOC_PV=1.5
-DESCRIPTION="Large array processing extension module for Python"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz
- doc? ( mirror://sourceforge/numpy/${PN}-${DOC_PV}.html.tar.gz )"
-HOMEPAGE="http://www.stsci.edu/resources/software_hardware/numarray"
-
-RDEPEND="lapack? ( virtual/cblas virtual/lapack )"
-
-DEPEND="${RDEPEND}
- lapack? ( dev-util/pkgconfig )"
-
-IUSE="doc lapack"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~s390 ~x86 ~x86-fbsd"
-LICENSE="BSD"
-
-DOCS="LICENSE.txt Doc/*.txt Doc/release_notes/ANNOUNCE-${PV:0:3}"
-
-# test with lapack buggy on amd64 (at least)
-#RESTRICT="amd64? ( lapack? ( test ) )"
-
-use lapack && unset LDFLAGS
-
-# ex usage: pkgconf_cfg --libs-only-l cblas: ['cblas','atlas']
-pkgconf_cfg() {
- local cfg="["
- for i in $(pkg-config "$@"); do
- cfg="${cfg}'${i:2}'"
- done
- echo "${cfg//\'\'/','}]"
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- # include Python.h from header files using the PyObject_HEAD macro.
- epatch "${FILESDIR}"/${P}-includes.patch
-
- # fix refcount problem from a debian bug
- epatch "${FILESDIR}"/${P}-refcount.patch
-
- # Fix missing exceptions (e.g. divide by zero, overflow) in FreeBSD
- # (i.e. need to include "__FreeBSD__" in pre-processor conditionals)
- epatch "${FILESDIR}"/${P}-freebsd.patch
-
- # fix only for python-2.5 (fix still uncomplete, see bug #191240)
- [[ "$(python_get_version)" == 2.5 ]] && epatch "${FILESDIR}"/${P}-python25.patch
-
- # array_protocol tests are buggy with various numeric/numpy versions
- sed -i \
- -e '/array_protocol/d' \
- Lib/testall.py || die "sed testall failed"
-
- # configure cfg_packages.py for lapack
- if use lapack; then
- sed -i \
- -e '/^if USE_LAPACK:/iUSE_LAPACK = True' \
- -e "s:\['/usr/local/lib/atlas'\]:$(pkgconf_cfg --libs-only-L cblas lapack):g" \
- -e "s:\[\"/usr/local/include/atlas\"\]:$(pkgconf_cfg --cflags-only-I cblas lapack):g" \
- -e "s:\['lapack', 'cblas', 'f77blas', 'atlas', 'g2c', 'm'\]:$(pkgconf_cfg --libs-only-l cblas lapack):g" \
- cfg_packages.py || die "sed for lapack failed"
- fi
-
- "$(PYTHON)" setup.py config --gencode || die "API code generation failed"
-}
-
-src_test() {
- cd build/lib*
- cp "${S}"/Lib/testdata.fits numarray
- PYTHONPATH=. "$(PYTHON)" -c \
- "from numarray.testall import test;import sys;sys.exit(test())" 2>&1 \
- | tee test.log
- grep -q -i failed test.log && die "failed tests in ${PWD}/test.log"
- rm -f numarray/testdata.fits test*.*
-}
-
-src_install() {
- distutils_src_install
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r Examples || die "install examples failed"
- dohtml "${WORKDIR}"/${PN}-${DOC_PV}/* || die "dohtml failed"
- fi
-}