summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-16 11:28:07 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-16 11:28:07 +0000
commit27f0eba973bc705c133975225e3f562d7d793054 (patch)
treeabdd4b4b630810959d3a6dd3b359bdbb37ad5427 /dev-python/numba
parentRemove Qt herd. (diff)
downloadgentoo-2-27f0eba973bc705c133975225e3f562d7d793054.tar.gz
gentoo-2-27f0eba973bc705c133975225e3f562d7d793054.tar.bz2
gentoo-2-27f0eba973bc705c133975225e3f562d7d793054.zip
bump; drop py2.6 py3.2 add py 3.4, drop redundant dep requ'd for py2.6, add IUSE doc for install of pdf file
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/numba')
-rw-r--r--dev-python/numba/ChangeLog8
-rw-r--r--dev-python/numba/numba-0.13.2.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/numba/ChangeLog b/dev-python/numba/ChangeLog
index 59aa6c7dc098..06840175080d 100644
--- a/dev-python/numba/ChangeLog
+++ b/dev-python/numba/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/numba
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v 1.4 2014/04/14 17:12:37 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/ChangeLog,v 1.5 2014/06/16 11:28:07 idella4 Exp $
+
+*numba-0.13.2 (16 Jun 2014)
+
+ 16 Jun 2014; Ian Delaney <idella4@gentoo.org> +numba-0.13.2.ebuild:
+ bump; drop py2.6 py3.2 add py 3.4, drop redundant dep requ'd for py2.6, add
+ IUSE doc for install of pdf file
*numba-0.13.0 (14 Apr 2014)
diff --git a/dev-python/numba/numba-0.13.2.ebuild b/dev-python/numba/numba-0.13.2.ebuild
new file mode 100644
index 000000000000..03965973a765
--- /dev/null
+++ b/dev-python/numba/numba-0.13.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numba/numba-0.13.2.ebuild,v 1.1 2014/06/16 11:28:07 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
+HOMEPAGE="http://numba.pydata.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/llvmpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c "import numba; numba.test()" || die
+}
+
+python_install_all() {
+ # doc needs obsolete sphnxjp package
+ use doc && dodoc docs/Numba.pdf
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}