summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2009-08-16 12:34:20 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2009-08-16 12:34:20 +0000
commit15312271bf4b6c53466d9347b9b002fdc89520f5 (patch)
treea8856df78b857582ab4dc16717be7119c2d830ef /dev-python/numpy
parentRemove "-l 255" from ZEBRA_OPTS (#279763). Bump version and add doc USE flag. (diff)
downloadgentoo-2-15312271bf4b6c53466d9347b9b002fdc89520f5.tar.gz
gentoo-2-15312271bf4b6c53466d9347b9b002fdc89520f5.tar.bz2
gentoo-2-15312271bf4b6c53466d9347b9b002fdc89520f5.zip
Fix arm/sh build
(Portage version: 2.2_rc36/cvs/Linux i686)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog6
-rw-r--r--dev-python/numpy/files/numpy-1.3.0-arm-sh.patch50
-rw-r--r--dev-python/numpy/numpy-1.3.0.ebuild3
3 files changed, 57 insertions, 2 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index dd4d53e7acc4..61003969f0b8 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.90 2009/08/09 16:45:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.91 2009/08/16 12:34:20 ford_prefect Exp $
+
+ 16 Aug 2009; Arun Raghavan <ford_prefect@gentoo.org> numpy-1.3.0.ebuild,
+ +files/numpy-1.3.0-arm-sh.patch:
+ Fix arm/sh build
09 Aug 2009; Raúl Porcel <armin76@gentoo.org> numpy-1.2.1.ebuild:
arm/sh stable
diff --git a/dev-python/numpy/files/numpy-1.3.0-arm-sh.patch b/dev-python/numpy/files/numpy-1.3.0-arm-sh.patch
new file mode 100644
index 000000000000..798eebb5aa7a
--- /dev/null
+++ b/dev-python/numpy/files/numpy-1.3.0-arm-sh.patch
@@ -0,0 +1,50 @@
+diff -urNp numpy-1.3.0-old/numpy/core/include/numpy/npy_cpu.h numpy-1.3.0-new/numpy/core/include/numpy/npy_cpu.h
+--- numpy-1.3.0-old/numpy/core/include/numpy/npy_cpu.h 2009-08-16 17:49:39.000000000 +0530
++++ numpy-1.3.0-new/numpy/core/include/numpy/npy_cpu.h 2009-08-16 17:49:19.000000000 +0530
+@@ -9,6 +9,10 @@
+ * NPY_CPU_S390
+ * NPY_CPU_IA64
+ * NPY_CPU_PARISC
++ * NPY_CPU_ARMEL
++ * NPY_CPU_ARMEB
++ * NPY_CPU_SH_LE
++ * NPY_CPU_SH_BE
+ */
+ #ifndef _NPY_CPUARCH_H_
+ #define _NPY_CPUARCH_H_
+@@ -46,6 +50,14 @@
+ #define NPY_CPU_PARISC
+ #elif defined(__alpha__)
+ #define NPY_CPU_ALPHA
++#elif defined(__arm__) && defined(__ARMEL__)
++ #define NPY_CPU_ARMEL
++#elif defined(__arm__) && defined(__ARMEB__)
++ #define NPY_CPU_ARMEB
++#elif defined(__sh__) && defined(__LITTLE_ENDIAN__)
++ #define NPY_CPU_SH_LE
++#elif defined(__sh__) && defined(__BIG_ENDIAN__)
++ #define NPY_CPU_SH_BE
+ #else
+ #error Unknown CPU, please report this to numpy maintainers with \
+ information about your platform (OS, CPU and compiler)
+diff -urNp numpy-1.3.0-old/numpy/core/include/numpy/npy_endian.h numpy-1.3.0-new/numpy/core/include/numpy/npy_endian.h
+--- numpy-1.3.0-old/numpy/core/include/numpy/npy_endian.h 2009-08-16 17:49:46.000000000 +0530
++++ numpy-1.3.0-new/numpy/core/include/numpy/npy_endian.h 2009-08-16 17:48:39.000000000 +0530
+@@ -22,11 +22,15 @@
+ #include "npy_cpu.h"
+
+ #if defined(NPY_CPU_X86) || defined(NPY_CPU_AMD64)\
+- || defined(NPY_CPU_IA64) || defined(NPY_CPU_ALPHA)
++ || defined(NPY_CPU_IA64) || defined(NPY_CPU_ALPHA)\
++ || defined(NPY_CPU_ARMEL)\
++ || defined(NPY_CPU_SH_LE)
+ #define NPY_LITTLE_ENDIAN
+ #define NPY_BYTE_ORDER 1234
+ #elif defined(NPY_CPU_PPC) || defined(NPY_CPU_SPARC)\
+- || defined(NPY_CPU_S390) || defined(NPY_CPU_PARISC)
++ || defined(NPY_CPU_S390) || defined(NPY_CPU_PARISC)\
++ || defined(NPY_CPU_ARMEB)\
++ || defined(NPY_CPU_SH_BE)
+ #define NPY_BIG_ENDIAN
+ #define NPY_BYTE_ORDER 4321
+ #else
diff --git a/dev-python/numpy/numpy-1.3.0.ebuild b/dev-python/numpy/numpy-1.3.0.ebuild
index f7d8e84f9532..298aa24a0b46 100644
--- a/dev-python/numpy/numpy-1.3.0.ebuild
+++ b/dev-python/numpy/numpy-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0.ebuild,v 1.8 2009/08/02 14:29:52 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0.ebuild,v 1.9 2009/08/16 12:34:20 ford_prefect Exp $
NEED_PYTHON=2.4
EAPI=2
@@ -45,6 +45,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-parisc.patch" # bug 277438
epatch "${FILESDIR}/${P}-alpha.patch" # bug 277438
+ epatch "${FILESDIR}/${P}-arm-sh.patch"
# Gentoo patch for ATLAS library names
sed -i \