summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-28 22:08:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-28 22:08:39 +0000
commit59c00cac1fd4e8d37cbee00fa0296c8272d358c3 (patch)
tree64f826d81d558a5bfbfba5145f321847e25aa28f /dev-python/numpy
parentMigrate to EAPI 2 in order to remove built_with_use usage. (diff)
downloadgentoo-2-59c00cac1fd4e8d37cbee00fa0296c8272d358c3.tar.gz
gentoo-2-59c00cac1fd4e8d37cbee00fa0296c8272d358c3.tar.bz2
gentoo-2-59c00cac1fd4e8d37cbee00fa0296c8272d358c3.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14166-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog8
-rw-r--r--dev-python/numpy/numpy-1.3.0-r1.ebuild122
2 files changed, 129 insertions, 1 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 1fd6759e846c..13b707ed6ea9 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.93 2009/08/28 17:49:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.94 2009/08/28 22:08:39 arfrever Exp $
+
+*numpy-1.3.0-r1 (28 Aug 2009)
+
+ 28 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +numpy-1.3.0-r1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
28 Aug 2009; Raúl Porcel <armin76@gentoo.org> numpy-1.3.0.ebuild:
arm/ia64/s390/sh stable wrt #277354
diff --git a/dev-python/numpy/numpy-1.3.0-r1.ebuild b/dev-python/numpy/numpy-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..3ecc7a2c8a20
--- /dev/null
+++ b/dev-python/numpy/numpy-1.3.0-r1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.3.0-r1.ebuild,v 1.1 2009/08/28 22:08:39 arfrever Exp $
+
+EAPI="2"
+
+NEED_PYTHON="2.4"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Fast array and numerical python library"
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://numpy.scipy.org/"
+
+RDEPEND="lapack? ( virtual/cblas virtual/lapack )"
+DEPEND="${RDEPEND}
+ lapack? ( dev-util/pkgconfig )
+ test? ( >=dev-python/nose-0.10 )"
+
+IUSE="lapack test"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+LICENSE="BSD"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+pkg_setup() {
+ # whatever LDFLAGS set will break linking
+ # see progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ if [[ -n "${LDFLAGS}" ]]; then
+ append-ldflags -shared
+ else
+ LDFLAGS="-shared"
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ use lapack || return
+ [[ -z ${FC} ]] && FC=$(tc-getFC)
+ # when fortran flags are set, pic is removed.
+ FFLAGS="${FFLAGS} -fPIC"
+ export NUMPY_FCONFIG="config_fc --noopt --noarch"
+}
+
+src_prepare() {
+ # Fix some paths and docs in f2py
+ epatch "${FILESDIR}"/${PN}-1.1.0-f2py.patch
+
+ epatch "${FILESDIR}/${P}-parisc.patch" # bug 277438
+ epatch "${FILESDIR}/${P}-alpha.patch" # bug 277438
+ epatch "${FILESDIR}/${P}-arm-sh.patch"
+
+ # Gentoo patch for ATLAS library names
+ sed -i \
+ -e "s:'f77blas':'blas':g" \
+ -e "s:'ptf77blas':'blas':g" \
+ -e "s:'ptcblas':'cblas':g" \
+ -e "s:'lapack_atlas':'lapack':g" \
+ numpy/distutils/system_info.py \
+ || die "sed system_info.py failed"
+
+ if use lapack; then
+ append-ldflags "$(pkg-config --libs-only-other cblas lapack)"
+ sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
+ cat >> site.cfg <<-EOF
+ [atlas]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas lapack | sed -e \
+ 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):/usr/$(get_libdir)
+ atlas_libs = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ lapack_libs = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [blas_opt]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):/usr/$(get_libdir)
+ libraries = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [lapack_opt]
+ library_dirs = $(pkg-config --libs-only-L \
+ lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):/usr/$(get_libdir)
+ libraries = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+}
+
+src_compile() {
+ distutils_src_compile ${NUMPY_FCONFIG}
+}
+
+src_test() {
+ testing() {
+ "$(PYTHON)" setup.py ${NUMPY_FCONFIG} build -b "build-${PYTHON_ABI}" install \
+ --home="${S}/test-${PYTHON_ABI}" --no-compile || die "install test failed"
+ pushd "${S}/test-${PYTHON_ABI}/"lib* > /dev/null
+ PYTHONPATH=python "$(PYTHON)" -c "import numpy; numpy.test()" 2>&1 | tee test.log
+ grep -q '^ERROR' test.log && die "test failed"
+ popd > /dev/null
+ rm -fr test-${PYTHON_ABI}
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install ${NUMPY_FCONFIG}
+ dodoc THANKS.txt DEV_README.txt COMPATIBILITY
+ rm -f "${D}"/usr/lib/python*/site-packages/numpy/*.txt || die
+ docinto f2py
+ dodoc numpy/f2py/docs/*.txt || die "dodoc f2py failed"
+ doman numpy/f2py/f2py.1 || die "doman failed"
+}