summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-16 10:44:27 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-16 10:44:27 +0000
commitb555d8dbd75054de5a666d79a6d70a1262f70ccc (patch)
tree811552605c9f26bc29e86ad6f035fd0239334b5d /dev-python/numpy
parentBlock old versions of dhcpcd to stop bugs like #143885. (diff)
downloadgentoo-2-b555d8dbd75054de5a666d79a6d70a1262f70ccc.tar.gz
gentoo-2-b555d8dbd75054de5a666d79a6d70a1262f70ccc.tar.bz2
gentoo-2-b555d8dbd75054de5a666d79a6d70a1262f70ccc.zip
version bump (#143964). restricted test because it does not work in sandbox.
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog7
-rw-r--r--dev-python/numpy/files/digest-numpy-1.0_beta23
-rw-r--r--dev-python/numpy/numpy-1.0_beta2.ebuild49
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index f1ba8c2f1299..7e6b1bc83162 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.9 2006/07/17 16:24:50 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.10 2006/08/16 10:44:27 liquidx Exp $
+
+*numpy-1.0_beta2 (16 Aug 2006)
+
+ 16 Aug 2006; Alastair Tse <liquidx@gentoo.org> +numpy-1.0_beta2.ebuild:
+ version bump (#143964). restricted test because it does not work in sandbox.
17 Jul 2006; Alastair Tse <liquidx@gentoo.org> -numpy-0.9.6.ebuild,
-numpy-0.9.6-r1.ebuild, numpy-0.9.8.ebuild:
diff --git a/dev-python/numpy/files/digest-numpy-1.0_beta2 b/dev-python/numpy/files/digest-numpy-1.0_beta2
new file mode 100644
index 000000000000..9643ac5b3567
--- /dev/null
+++ b/dev-python/numpy/files/digest-numpy-1.0_beta2
@@ -0,0 +1,3 @@
+MD5 6aa929f8156b3fa2fc230a10ccef3353 numpy-1.0b2.tar.gz 1094555
+RMD160 1d0e90d87af7711ff7d7bea3e4270a41738d7dd4 numpy-1.0b2.tar.gz 1094555
+SHA256 8f7ee8b75349102170169c1ca6c652341708d9137a35196d6505dd47ea608f49 numpy-1.0b2.tar.gz 1094555
diff --git a/dev-python/numpy/numpy-1.0_beta2.ebuild b/dev-python/numpy/numpy-1.0_beta2.ebuild
new file mode 100644
index 000000000000..9eea76a2786b
--- /dev/null
+++ b/dev-python/numpy/numpy-1.0_beta2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.0_beta2.ebuild,v 1.1 2006/08/16 10:44:27 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Multi-dimensional array object and processing for Python."
+SRC_URI="mirror://sourceforge/numpy/${MY_P}.tar.gz"
+HOMEPAGE="http://numeric.scipy.org/"
+# numpy provides the latest version of dev-python/f2py
+DEPEND=">=dev-lang/python-2.3
+ !dev-python/f2py
+ lapack? ( virtual/blas
+ virtual/lapack )"
+IUSE="lapack"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="BSD"
+RESTRICT="test"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # sed to patch ATLAS libraries names (gentoo specific)
+ sed -i \
+ -e "s:f77blas:blas:g" \
+ numpy/distutils/system_info.py
+
+ if use lapack; then
+ echo "[atlas]" > site.cfg
+ echo "include_dirs = /usr/include/atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack:" >> site.cfg
+ if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
+ echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
+ else
+ echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
+ fi
+ else
+ export ATLAS=None
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc numpy/doc/*
+}