summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-06-14 01:07:00 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-06-14 01:07:00 +0000
commiteeef923fcb4c591e05911349e9a4456351589301 (patch)
treead607ba43983891f77ceb942076d70df4d88bf8f /dev-python/numpy
parentFixed PDL for lib64 (diff)
downloadgentoo-2-eeef923fcb4c591e05911349e9a4456351589301.tar.gz
gentoo-2-eeef923fcb4c591e05911349e9a4456351589301.tar.bz2
gentoo-2-eeef923fcb4c591e05911349e9a4456351589301.zip
Bump. Incorporates many changes from the science overlay, mainly from bicatali.
(Portage version: 2.1)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog7
-rw-r--r--dev-python/numpy/files/digest-numpy-0.9.83
-rw-r--r--dev-python/numpy/numpy-0.9.8.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 4fc9044f5bda..ae4ee8e731ba 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.7 2006/06/13 23:34:12 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.8 2006/06/14 01:06:59 spyderous Exp $
+
+*numpy-0.9.8 (14 Jun 2006)
+
+ 14 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>; +numpy-0.9.8.ebuild:
+ Bump. Incorporates many changes from the science overlay, mainly from bicatali.
13 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>; metadata.xml:
Add sci herd as co-maintainer.
diff --git a/dev-python/numpy/files/digest-numpy-0.9.8 b/dev-python/numpy/files/digest-numpy-0.9.8
new file mode 100644
index 000000000000..89baced470c9
--- /dev/null
+++ b/dev-python/numpy/files/digest-numpy-0.9.8
@@ -0,0 +1,3 @@
+MD5 ca528d2b460a6567d70bb6bdf0dc1805 numpy-0.9.8.tar.gz 985088
+RMD160 6059d103ae0c89f946da906f0cddcb9cd1f6b59b numpy-0.9.8.tar.gz 985088
+SHA256 1cac3bb08d5a64b9877eb458b7235bf33bdb591136cb08e4561b6210756750c1 numpy-0.9.8.tar.gz 985088
diff --git a/dev-python/numpy/numpy-0.9.8.ebuild b/dev-python/numpy/numpy-0.9.8.ebuild
new file mode 100644
index 000000000000..c3c94ea90834
--- /dev/null
+++ b/dev-python/numpy/numpy-0.9.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-0.9.8.ebuild,v 1.1 2006/06/14 01:06:59 spyderous Exp $
+
+inherit distutils
+
+DESCRIPTION="Multi-dimensional array object and processing for Python."
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://numeric.scipy.org/"
+DEPEND=">=dev-lang/python-2.3
+ lapack? ( virtual/blas
+ virtual/lapack )"
+IUSE="lapack"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="BSD"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # sed to patch ATLAS libraries names (gentoo specific)
+ sed -i \
+ -e "s:f77blas:blas:g" \
+ numpy/distutils/system_info.py
+
+ if use lapack; then
+ echo "[atlas]" > site.cfg
+ echo "include_dirs = /usr/include/atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack:" >> site.cfg
+ if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
+ echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
+ else
+ echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
+ fi
+ else
+ export ATLAS=None
+ fi
+}
+
+# The test only works after install
+# To be worked out.
+#src_test() {
+# python -c "import numpy; numpy.test()" || \
+# die "test failed!"
+#}
+
+src_install() {
+ distutils_src_install
+ dodoc numpy/doc/*
+}
+
+