summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-18 06:24:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-18 06:24:42 +0000
commit5905f0a2a73dbcce2192ec879ec3df62e1fedec2 (patch)
tree799e6b86717ac9cc599fdb6bc099ac36551f0373 /dev-python/oauthlib
parentapp-backup/deja-dup: Add missing runtime dep on dconf, #483520 (diff)
downloadgentoo-2-5905f0a2a73dbcce2192ec879ec3df62e1fedec2.tar.gz
gentoo-2-5905f0a2a73dbcce2192ec879ec3df62e1fedec2.tar.bz2
gentoo-2-5905f0a2a73dbcce2192ec879ec3df62e1fedec2.zip
Bump
(Portage version: 2.2.6/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/ChangeLog7
-rw-r--r--dev-python/oauthlib/oauthlib-0.6.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-python/oauthlib/ChangeLog b/dev-python/oauthlib/ChangeLog
index 4b4e9cf935c1..210a2f9d60bf 100644
--- a/dev-python/oauthlib/ChangeLog
+++ b/dev-python/oauthlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oauthlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.29 2013/09/05 18:46:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/ChangeLog,v 1.30 2013/09/18 06:24:42 patrick Exp $
+
+*oauthlib-0.6.0 (18 Sep 2013)
+
+ 18 Sep 2013; Patrick Lauer <patrick@gentoo.org> +oauthlib-0.6.0.ebuild:
+ Bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> oauthlib-0.3.6.ebuild,
oauthlib-0.3.7.ebuild, oauthlib-0.3.8.ebuild, oauthlib-0.4.0.ebuild,
diff --git a/dev-python/oauthlib/oauthlib-0.6.0.ebuild b/dev-python/oauthlib/oauthlib-0.6.0.ebuild
new file mode 100644
index 000000000000..2e30e71d3236
--- /dev/null
+++ b/dev-python/oauthlib/oauthlib-0.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oauthlib/oauthlib-0.6.0.ebuild,v 1.1 2013/09/18 06:24:42 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+HOMEPAGE="https://github.com/idan/oauthlib http://pypi.python.org/pypi/oauthlib"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+# >=pycrypto-2.6-r1 for python3 support
+# unittest2 for python2 compat
+RDEPEND=">=dev-python/pycrypto-2.6-r1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/python-unittest2[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests || die
+}