summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-25 11:27:26 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-25 11:27:26 +0000
commit53c6b8149dae5d6dbd1c1eba1f3890fd5359f2b4 (patch)
tree07cb76315e3a076af30f829690032de1ff81eae9 /dev-python/pandas
parentRemoving older versions (diff)
downloadgentoo-2-53c6b8149dae5d6dbd1c1eba1f3890fd5359f2b4.tar.gz
gentoo-2-53c6b8149dae5d6dbd1c1eba1f3890fd5359f2b4.tar.bz2
gentoo-2-53c6b8149dae5d6dbd1c1eba1f3890fd5359f2b4.zip
set no-strict-aliasing under py2.7, revise sed statement, correct doc location for dohtml, fixes Bug #514870
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/ChangeLog6
-rw-r--r--dev-python/pandas/pandas-0.14.0.ebuild22
2 files changed, 19 insertions, 9 deletions
diff --git a/dev-python/pandas/ChangeLog b/dev-python/pandas/ChangeLog
index 1c17f06888ef..f84e7cfc56f5 100644
--- a/dev-python/pandas/ChangeLog
+++ b/dev-python/pandas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pandas
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/ChangeLog,v 1.25 2014/06/24 06:03:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/ChangeLog,v 1.26 2014/06/25 11:27:26 idella4 Exp $
+
+ 25 Jun 2014; Ian Delaney <idella4@gentoo.org> pandas-0.14.0.ebuild:
+ set no-strict-aliasing under py2.7, revise sed statement, correct doc location
+ for dohtml, fixes Bug #514870
24 Jun 2014; Patrick Lauer <patrick@gentoo.org> pandas-0.14.0.ebuild:
Whitespace
diff --git a/dev-python/pandas/pandas-0.14.0.ebuild b/dev-python/pandas/pandas-0.14.0.ebuild
index 9dc91cfd76dd..a9dccbe83361 100644
--- a/dev-python/pandas/pandas-0.14.0.ebuild
+++ b/dev-python/pandas/pandas-0.14.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/pandas-0.14.0.ebuild,v 1.2 2014/06/24 06:03:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pandas/pandas-0.14.0.ebuild,v 1.3 2014/06/25 11:27:26 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
-inherit distutils-r1 virtualx
+inherit distutils-r1 virtualx flag-o-matic
DESCRIPTION="Powerful data structures for data analysis and statistics"
HOMEPAGE="http://pandas.sourceforge.net/"
@@ -69,12 +69,9 @@ RDEPEND="${CDEPEND}
python_prepare_all() {
if use doc; then
# Prevent un-needed download during build
- sed -e 's:^intersphinx_mapping:#intersphinx_mapping:' \
- -e "s:^ 'statsmodels:# 'statsmodels:" \
- -e "s:^ 'python:# 'python:" \
- -e "s:^}:#}:" \
- -i doc/source/conf.py || die
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/source/conf.py || die
fi
+
distutils-r1_python_prepare_all
}
@@ -88,6 +85,15 @@ python_compile_all() {
fi
}
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+
+ distutils-r1_python_compile
+}
+
src_test() {
local DISTUTILS_NO_PARALLEL_BUILD=1
distutils-r1_src_test
@@ -103,7 +109,7 @@ python_test() {
python_install_all() {
if use doc; then
- dohtml -r "${BUILD_DIR}"/lib/doc/build/html/*
+ dohtml -r "${BUILD_DIR}"/lib/doc/build/html/
einfo "An initial build of docs is absent of references to statsmodels"
einfo "due to circular dependency. To have them included, emerge"
einfo "statsmodels next and re-emerge pandas with USE doc"