summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-02-17 17:19:12 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-02-17 17:19:12 +0000
commit18e5d47e04ff2e964427cca1e58a899bd3124e15 (patch)
tree563e8a9adb1a9935db6e795488a0e5a7efa7d40b /dev-python/pbr
parentSecurity mask - bug #492494 net-mail/dovecot-2.{0,1} (diff)
downloadgentoo-2-18e5d47e04ff2e964427cca1e58a899bd3124e15.tar.gz
gentoo-2-18e5d47e04ff2e964427cca1e58a899bd3124e15.tar.bz2
gentoo-2-18e5d47e04ff2e964427cca1e58a899bd3124e15.zip
fixing some py32 problems and adding py32 support
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/ChangeLog7
-rw-r--r--dev-python/pbr/pbr-0.5.23-r2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-python/pbr/ChangeLog b/dev-python/pbr/ChangeLog
index 7d2f4fcb940a..1288fe0289e8 100644
--- a/dev-python/pbr/ChangeLog
+++ b/dev-python/pbr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pbr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.9 2014/01/21 01:43:35 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/ChangeLog,v 1.10 2014/02/17 17:19:12 prometheanfire Exp $
+
+*pbr-0.5.23-r2 (17 Feb 2014)
+
+ 17 Feb 2014; Matthew Thode <prometheanfire@gentoo.org> +pbr-0.5.23-r2.ebuild:
+ fixing some py32 problems and adding py32 support
*pbr-0.5.23-r1 (21 Jan 2014)
diff --git a/dev-python/pbr/pbr-0.5.23-r2.ebuild b/dev-python/pbr/pbr-0.5.23-r2.ebuild
new file mode 100644
index 000000000000..df82b49451ff
--- /dev/null
+++ b/dev-python/pbr/pbr-0.5.23-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pbr/pbr-0.5.23-r2.ebuild,v 1.1 2014/02/17 17:19:12 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="PBR is a library that injects some useful and sensible default
+behaviors into your setuptools run."
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.12[${PYTHON_USEDEP}]
+ ~dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ <dev-python/testresources-0.3[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ <dev-python/testscenarios-0.5[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}] )"
+RDEPEND=">dev-python/pip-1.0[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ if [[ "${EPYTHON}" == "python3.2" ]]; then
+ 2to3-3.2 -f unicode -nw --no-diffs pbr
+ fi
+}
+
+python_test() {
+ # These tests pass run within the source and don't represent failures but rather
+ # work outside the sandbox constraints
+ sed -e s':test_changelog:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_console_script_develop:_&:' -i pbr/tests/test_core.py || die
+
+ sed -e s':test_authors:_&:' -i pbr/tests/test_packaging.py || die
+ sed -e s':test_global_setup_hooks:_&:' -i pbr/tests/test_hooks.py \
+ -e s':test_custom_commands_known:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -i pbr/tests/test_hooks.py
+ sed -e s':test_setup_py_keywords:_&:' \
+ -e s':test_sdist_git_extra_file:_&:' \
+ -e s':test_sdist_extra_file:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_custom_build_py_command:_&:' \
+ -i pbr/tests/test_commands.py || die
+
+ testr init
+ testr run || die "Testsuite failed under ${EPYTHON}"
+ flake8 "${PN}"/tests || die "Run over tests folder by flake8 drew error"
+}