summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-17 00:42:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-17 00:42:16 +0000
commit6d1d9f64b8ed8d486f75ef82e1bad34dcc775844 (patch)
tree3d9bdace6cc7b3f29eb6a36d6cfd1b66f2ed8d77 /dev-python/psycopg
parentVersion bump. (diff)
downloadgentoo-2-6d1d9f64b8ed8d486f75ef82e1bad34dcc775844.tar.gz
gentoo-2-6d1d9f64b8ed8d486f75ef82e1bad34dcc775844.tar.bz2
gentoo-2-6d1d9f64b8ed8d486f75ef82e1bad34dcc775844.zip
Version bump.
(Portage version: 2.2.0_alpha33_p31/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog8
-rw-r--r--dev-python/psycopg/psycopg-2.4.1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index 4d4a48643beb..3d82805fc391 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.124 2011/04/29 20:18:13 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.125 2011/05/17 00:42:16 arfrever Exp $
+
+*psycopg-2.4.1 (17 May 2011)
+
+ 17 May 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +psycopg-2.4.1.ebuild:
+ Version bump.
29 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> psycopg-2.4.ebuild:
ppc64 stable wrt #361523
diff --git a/dev-python/psycopg/psycopg-2.4.1.ebuild b/dev-python/psycopg/psycopg-2.4.1.ebuild
new file mode 100644
index 000000000000..ee21e11214ba
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.4.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.4.1.ebuild,v 1.1 2011/05/17 00:42:16 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
+
+inherit distutils eutils
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples mxdatetime"
+
+RDEPEND=">=dev-db/postgresql-base-8.1
+ mxdatetime? ( dev-python/egenix-mx-base )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="AUTHORS doc/HACKING doc/SUCCESS"
+PYTHON_MODNAME="${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.12-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+
+ python_convert_shebangs 2 doc/src/tools/stitch_text.py
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
+ fi
+
+ if use mxdatetime; then
+ sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
+ fi
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd doc > /dev/null
+ emake -j1 html text || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dodoc doc/psycopg2.txt || die "dodoc failed"
+
+ pushd doc/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}