summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-16 18:43:04 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-16 18:43:04 +0000
commitc6c9214ced8d2812bce4421025b01eeb5c08bde7 (patch)
treeb07da3663c80ed5b9c5472238289c4bb19183c42 /dev-python/psycopg
parentDelete older ebuild. (diff)
downloadgentoo-2-c6c9214ced8d2812bce4421025b01eeb5c08bde7.tar.gz
gentoo-2-c6c9214ced8d2812bce4421025b01eeb5c08bde7.tar.bz2
gentoo-2-c6c9214ced8d2812bce4421025b01eeb5c08bde7.zip
Version bump.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog8
-rw-r--r--dev-python/psycopg/psycopg-2.0.14.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index a727d63c1e85..4f5247376255 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.96 2010/01/25 19:31:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.97 2010/04/16 18:43:04 arfrever Exp $
+
+*psycopg-2.0.14 (16 Apr 2010)
+
+ 16 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -psycopg-2.0.12.ebuild, +psycopg-2.0.14.ebuild:
+ Version bump.
25 Jan 2010; Raúl Porcel <armin76@gentoo.org> psycopg-2.0.13.ebuild:
ia64/sparc stable wrt #296676
diff --git a/dev-python/psycopg/psycopg-2.0.14.ebuild b/dev-python/psycopg/psycopg-2.0.14.ebuild
new file mode 100644
index 000000000000..309561619131
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.0.14.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.0.14.ebuild,v 1.1 2010/04/16 18:43:04 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="http://initd.org/pub/software/psycopg/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples mxdatetime"
+
+DEPEND=">=virtual/postgresql-base-8.1
+ mxdatetime? ( dev-python/egenix-mx-base )"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS doc/HACKING doc/psycopg2.txt doc/SUCCESS"
+PYTHON_MODNAME="${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.12-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
+ fi
+
+ if use mxdatetime; then
+ sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd doc/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}