summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-01-11 22:57:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-01-11 22:57:14 +0000
commit5d058a877817e7d1140a8878b6ee326435ab535a (patch)
tree1a0853324cd96805d3681b7e4134c0928bff3f49 /dev-python/pychart/pychart-1.39.ebuild
parentstable x86, bug #161193 (diff)
downloadgentoo-2-5d058a877817e7d1140a8878b6ee326435ab535a.tar.gz
gentoo-2-5d058a877817e7d1140a8878b6ee326435ab535a.tar.bz2
gentoo-2-5d058a877817e7d1140a8878b6ee326435ab535a.zip
Added docs, bug #154792. Cleaned-up the dependencies and some other stuff.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'dev-python/pychart/pychart-1.39.ebuild')
-rw-r--r--dev-python/pychart/pychart-1.39.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/dev-python/pychart/pychart-1.39.ebuild b/dev-python/pychart/pychart-1.39.ebuild
index 12a8973b29c4..0127c23dbbcc 100644
--- a/dev-python/pychart/pychart-1.39.ebuild
+++ b/dev-python/pychart/pychart-1.39.ebuild
@@ -1,28 +1,33 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pychart/pychart-1.39.ebuild,v 1.3 2006/11/11 17:35:25 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pychart/pychart-1.39.ebuild,v 1.4 2007/01/11 22:57:14 dev-zero Exp $
inherit distutils
-MY_P=${P/pychart/PyChart}
+MY_P=PyChart-${PV}
+
DESCRIPTION="Python library for creating charts"
HOMEPAGE="http://home.gna.org/pychart/"
-SRC_URI="http://download.gna.org/pychart/${MY_P}.tar.gz"
+SRC_URI="http://download.gna.org/pychart/${MY_P}.tar.gz
+ doc? ( http://download.gna.org/pychart/${PN}-doc.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
-IUSE=""
+IUSE="doc examples"
-DEPEND=">=dev-lang/python-2.2.2
- >=sys-apps/sed-4
- virtual/ghostscript"
+DEPEND="virtual/ghostscript"
S=${WORKDIR}/${MY_P}
src_install() {
distutils_src_install
- insinto /usr/share/doc/${PF}/demos
- doins demos/*
+ if use doc ; then
+ dohtml -r ${WORKDIR}/${PN}/*
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins demos/*
+ fi
}