summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-12-25 11:11:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-12-25 11:11:00 +0000
commit44bc280d227f0b6eba06f7e6f0413d24da3f0d3a (patch)
tree9388df03c3a873b27a1fea68dd016ba546d161ab /dev-python/pyconstruct
parentBump for #393613 (diff)
downloadgentoo-2-44bc280d227f0b6eba06f7e6f0413d24da3f0d3a.tar.gz
gentoo-2-44bc280d227f0b6eba06f7e6f0413d24da3f0d3a.tar.bz2
gentoo-2-44bc280d227f0b6eba06f7e6f0413d24da3f0d3a.zip
Bump for #393609
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyconstruct')
-rw-r--r--dev-python/pyconstruct/ChangeLog7
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.06.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/pyconstruct/ChangeLog b/dev-python/pyconstruct/ChangeLog
index 01f5d0fc80c6..0e1d9f8a5a5d 100644
--- a/dev-python/pyconstruct/ChangeLog
+++ b/dev-python/pyconstruct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyconstruct
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.3 2011/09/16 08:24:21 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.4 2011/12/25 11:11:00 patrick Exp $
+
+*pyconstruct-2.06 (25 Dec 2011)
+
+ 25 Dec 2011; Patrick Lauer <patrick@gentoo.org> +pyconstruct-2.06.ebuild:
+ Bump for #393609
*pyconstruct-2.04 (16 Sep 2011)
diff --git a/dev-python/pyconstruct/pyconstruct-2.06.ebuild b/dev-python/pyconstruct/pyconstruct-2.06.ebuild
new file mode 100644
index 000000000000..39f06b3dcdbe
--- /dev/null
+++ b/dev-python/pyconstruct/pyconstruct-2.06.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.06.ebuild,v 1.1 2011/12/25 11:11:00 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+
+inherit distutils
+
+MY_PN="construct"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ cd docs
+ PYTHONPATH=".." emake html || die "Building of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html/* || die "Installation of documentation failed"
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize construct
+}
+
+pkg_postrm() {
+ python_mod_cleanup construct
+}