summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 19:04:28 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-08 19:04:28 +0000
commit9633b6e4546176134d89f379b6415a92371686df (patch)
treec468e2d40e615562949baa17663593a426f11288 /dev-python/pyconstruct
parentOracle exchanged the tarballs on their download server without ver-/revbump. (diff)
downloadgentoo-2-9633b6e4546176134d89f379b6415a92371686df.tar.gz
gentoo-2-9633b6e4546176134d89f379b6415a92371686df.tar.bz2
gentoo-2-9633b6e4546176134d89f379b6415a92371686df.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyconstruct')
-rw-r--r--dev-python/pyconstruct/ChangeLog8
-rw-r--r--dev-python/pyconstruct/pyconstruct-2.0.0.ebuild49
2 files changed, 24 insertions, 33 deletions
diff --git a/dev-python/pyconstruct/ChangeLog b/dev-python/pyconstruct/ChangeLog
index cbaae3c58e39..945a6f35c8d4 100644
--- a/dev-python/pyconstruct/ChangeLog
+++ b/dev-python/pyconstruct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyconstruct
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.1 2009/02/03 21:05:58 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/ChangeLog,v 1.2 2010/06/08 19:04:28 arfrever Exp $
+
+ 08 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pyconstruct-2.0.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
*pyconstruct-2.0.0 (03 Feb 2009)
diff --git a/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild b/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
index d5ac20a7be44..ced4cf34ea74 100644
--- a/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
+++ b/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild
@@ -1,53 +1,40 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild,v 1.1 2009/02/03 21:05:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyconstruct/pyconstruct-2.0.0.ebuild,v 1.2 2010/06/08 19:04:28 arfrever Exp $
-inherit python
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
-DESCRIPTION="Simple parsing of binary (and textual) data with Python"
-HOMEPAGE="http://construct.wikispaces.com/"
+inherit python
-# TODO
-# tests are quite large, upstream provides extra dist with them
-#SRC_URI="
-# !test? ( mirror://sourceforge/pyconstruct/construct-${PV}-distro.zip )
-# test? ( mirror://sourceforge/pyconstruct/construct-${PV}-full.zip )
-#"
-# Upstream labels it as 2.00
+DESCRIPTION="Library for constructing (parsing and building) of binary and textual data structures"
+HOMEPAGE="http://construct.wikispaces.com/ http://pypi.python.org/pypi/construct"
SRC_URI="mirror://sourceforge/pyconstruct/construct-2.00-distro.zip"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64"
-#IUSE="test"
IUSE=""
-DEPEND=""
-RDEPEND=">=dev-lang/python-2.5"
+DEPEND="app-arch/unzip"
+RDEPEND=""
S="${WORKDIR}/construct"
-src_compile() {
- # Hello World! :-)
- einfo Nothing to compile
-}
-
src_install() {
- # upstream "doesn't believe in setups"
- python_version
- dodir /usr/lib/python${PYVER}/site-packages
- cp -ra "${S}" "${D}"/usr/lib/python${PYVER}/site-packages || die
+ installation() {
+ insinto $(python_get_sitedir)/construct
+ doins -r *
+ }
+ python_execute_function installation
}
-#src_test() {
-# echo TODO :-/
-#}
-
pkg_postinst() {
- python_version
- python_mod_optimize "${ROOT}"usr/lib/python${PYVER}/site-packages/${PN}
+ python_mod_optimize construct
}
pkg_postrm() {
- python_mod_cleanup
+ python_mod_cleanup construct
}