summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 02:54:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 02:54:41 +0000
commit4b7284b7e22592c3d2d2c77f47510dd5a6557b3d (patch)
treee92fb319c84b3aea1806af93e30ba961bf161e3c /dev-python/pycxx/pycxx-6.1.0.ebuild
parentfix building with gcc44 with patch from Fredric Johansson (bug #274001) (diff)
downloadgentoo-2-4b7284b7e22592c3d2d2c77f47510dd5a6557b3d.tar.gz
gentoo-2-4b7284b7e22592c3d2d2c77f47510dd5a6557b3d.tar.bz2
gentoo-2-4b7284b7e22592c3d2d2c77f47510dd5a6557b3d.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 13918-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycxx/pycxx-6.1.0.ebuild')
-rw-r--r--dev-python/pycxx/pycxx-6.1.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pycxx/pycxx-6.1.0.ebuild b/dev-python/pycxx/pycxx-6.1.0.ebuild
new file mode 100644
index 000000000000..dbfe86558203
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.1.0.ebuild,v 1.1 2009/08/05 02:54:41 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils distutils
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+PYTHON_MODNAME="CXX"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-setup.py.patch"
+ epatch "${FILESDIR}/${P}-python-3.patch"
+ epatch "${FILESDIR}/${P}-C_compatible_headers.patch"
+}
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r Doc/ || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples/python-2
+ dodoc Demo/Python2/* || die "dodoc failed"
+ docinto examples/python-3
+ dodoc Demo/Python3/* || die "dodoc failed"
+ fi
+}