summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-08-28 00:01:20 +0000
committerMike Gilbert <floppym@gentoo.org>2013-08-28 00:01:20 +0000
commit85a3694d535ce16b21c1ba54f44a51af80d02889 (patch)
tree5998c555e5820e86a7a8ccb01846b692db74c57d /dev-python/pycxx
parentVersion bump to 9.2. (diff)
downloadgentoo-2-85a3694d535ce16b21c1ba54f44a51af80d02889.tar.gz
gentoo-2-85a3694d535ce16b21c1ba54f44a51af80d02889.tar.bz2
gentoo-2-85a3694d535ce16b21c1ba54f44a51af80d02889.zip
Version bump. Convert to distutils-r1.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/pycxx')
-rw-r--r--dev-python/pycxx/ChangeLog10
-rw-r--r--dev-python/pycxx/pycxx-6.2.5.ebuild37
2 files changed, 44 insertions, 3 deletions
diff --git a/dev-python/pycxx/ChangeLog b/dev-python/pycxx/ChangeLog
index 8ad1e90d5f82..34714dc2c514 100644
--- a/dev-python/pycxx/ChangeLog
+++ b/dev-python/pycxx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycxx
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.45 2012/06/08 11:34:54 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/ChangeLog,v 1.46 2013/08/28 00:01:20 floppym Exp $
+
+*pycxx-6.2.5 (28 Aug 2013)
+
+ 28 Aug 2013; Mike Gilbert <floppym@gentoo.org> +pycxx-6.2.5.ebuild:
+ Version bump. Convert to distutils-r1.
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> pycxx-6.2.4-r1.ebuild:
x86 stable wrt bug #418907
@@ -181,4 +186,3 @@
15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+files/pycxx-5.4.2-headers-c.patch, +metadata.xml, +pycxx-5.4.2.ebuild:
Initial import
-
diff --git a/dev-python/pycxx/pycxx-6.2.5.ebuild b/dev-python/pycxx/pycxx-6.2.5.ebuild
new file mode 100644
index 000000000000..0205eb10f08a
--- /dev/null
+++ b/dev-python/pycxx/pycxx-6.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycxx/pycxx-6.2.5.ebuild,v 1.1 2013/08/28 00:01:20 floppym Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Set of facilities to extend Python with C++"
+HOMEPAGE="http://cxx.sourceforge.net"
+SRC_URI="mirror://sourceforge/cxx/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="doc examples"
+
+python_prepare_all() {
+ # Without this, pysvn fails.
+ # CXX/Python2/Config.hxx: No such file or directory
+ sed -e "/^#include/s:/Python[23]/:/:" -i CXX/*/*.hxx || die "sed failed"
+
+ # Remove python2 print statement
+ echo > Lib/__init__.py || die
+
+ local PATCHES=(
+ "${FILESDIR}/${PN}-6.2.3-installation.patch"
+ )
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( Doc/ )
+ use examples && local EXAMPLES=( Demo/Python{2,3}/ )
+ distutils-r1_python_install_all
+}