summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2012-06-24 12:22:55 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2012-06-24 12:22:55 +0000
commit0f22ed209587651b1538beb4bf16857054a38813 (patch)
treec2550336b4fc6bde2be343e4d31d0ba8fe7a2647 /dev-python/pydns
parentfixing compile-error, solving bug #423065. (diff)
downloadgentoo-2-0f22ed209587651b1538beb4bf16857054a38813.tar.gz
gentoo-2-0f22ed209587651b1538beb4bf16857054a38813.tar.bz2
gentoo-2-0f22ed209587651b1538beb4bf16857054a38813.zip
version bump, removed obsolete ebuild, solving bug #416377.
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pydns')
-rw-r--r--dev-python/pydns/ChangeLog9
-rw-r--r--dev-python/pydns/pydns-2.3.6.ebuild (renamed from dev-python/pydns/pydns-2.3.5.ebuild)28
-rw-r--r--dev-python/pydns/pydns-3.0.2.ebuild48
3 files changed, 74 insertions, 11 deletions
diff --git a/dev-python/pydns/ChangeLog b/dev-python/pydns/ChangeLog
index 2a5382a794e4..12ca6da4ab15 100644
--- a/dev-python/pydns/ChangeLog
+++ b/dev-python/pydns/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pydns
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/ChangeLog,v 1.13 2012/04/05 06:16:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/ChangeLog,v 1.14 2012/06/24 12:22:55 sbriesen Exp $
+
+*pydns-3.0.2 (24 Jun 2012)
+*pydns-2.3.6 (24 Jun 2012)
+
+ 24 Jun 2012; Stefan Briesenick <sbriesen@gentoo.org> -pydns-2.3.5.ebuild,
+ +pydns-2.3.6.ebuild, +pydns-3.0.2.ebuild:
+ version bump, removed obsolete ebuild, solving bug #416377.
05 Apr 2012; Jeff Horelick <jdhore@gentoo.org> pydns-3.0.1.ebuild:
marked x86 per bug 404715
diff --git a/dev-python/pydns/pydns-2.3.5.ebuild b/dev-python/pydns/pydns-2.3.6.ebuild
index 8e0eb3592b44..f8a7b406aa54 100644
--- a/dev-python/pydns/pydns-2.3.5.ebuild
+++ b/dev-python/pydns/pydns-2.3.6.ebuild
@@ -1,26 +1,28 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-2.3.5.ebuild,v 1.1 2011/07/10 00:51:10 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-2.3.6.ebuild,v 1.1 2012/06/24 12:22:55 sbriesen Exp $
-EAPI="2"
+EAPI="4"
+PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
DESCRIPTION="Python module for DNS (Domain Name Service)"
HOMEPAGE="http://pydns.sourceforge.net/ http://pypi.python.org/pypi/pydns"
-SRC_URI="http://downloads.sourceforge.net/project/${PN}/${PN}/${P}/${P}.tar.gz"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/pydns/${P}/${P}.tar.gz"
LICENSE="CNRI"
-SLOT="0"
+SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND="virtual/libiconv"
+DEPEND="!dev-python/pydns:0
+ virtual/libiconv"
RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-DOCS="CREDITS.txt"
+DOCS="CREDITS"
PYTHON_MODNAME="DNS"
src_prepare() {
@@ -30,10 +32,15 @@ src_prepare() {
done
# Don't compile bytecode.
- sed -i -e 's:^\(compile\).*:\1 = 0:g' -e 's:^\(optimize\).*:\1 = 0:g' setup.cfg
+ sed -i -e 's:^\(compile\|optimize\).*:\1 = 0:g' setup.cfg
# Fix Python shebangs in examples.
- sed -i -e 's:#!/.*\(python\).*/*$:#!/usr/bin/\12:g' {tests,tools}/*.py
+ python_convert_shebangs -r 2 .
+
+ # cleanup docs
+ rm -f -- "README-guido.txt"
+ mv -f -- "README.txt" "README"
+ mv -f -- "CREDITS.txt" "CREDITS"
}
src_install(){
@@ -41,6 +48,7 @@ src_install(){
if use examples; then
insinto /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/examples
doins tests/*.py tools/*.py
fi
}
diff --git a/dev-python/pydns/pydns-3.0.2.ebuild b/dev-python/pydns/pydns-3.0.2.ebuild
new file mode 100644
index 000000000000..28b6db9267f9
--- /dev/null
+++ b/dev-python/pydns/pydns-3.0.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pydns/pydns-3.0.2.ebuild,v 1.1 2012/06/24 12:22:55 sbriesen Exp $
+
+EAPI="4"
+PYTHON_DEPEND="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.*"
+
+inherit distutils
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/ http://pypi.python.org/pypi/pydns"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/py3dns/${P/py/py3}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="!dev-python/py3dns
+ virtual/libiconv"
+RDEPEND=""
+
+DOCS="CHANGES CREDITS"
+PYTHON_MODNAME="DNS"
+
+S="${WORKDIR}/${P/py/py3}"
+
+src_prepare() {
+ # Don't compile bytecode.
+ sed -i -e 's:^\(compile\|optimize\).*:\1 = 0:g' setup.cfg
+
+ # cleanup docs
+ rm -f -- "README-guido.txt"
+ mv -f -- "README.txt" "README"
+ mv -f -- "CREDITS.txt" "CREDITS"
+}
+
+src_install(){
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ doins tests/*.py tools/*.py
+ fi
+}